mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
a1383655cf
Tested on bcm2710 (Raspberry Pi 3B). Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
124 lines
3.7 KiB
Diff
124 lines
3.7 KiB
Diff
From 2f7b03ee22ad1597dc2f21797466ac477997b06f Mon Sep 17 00:00:00 2001
|
|
From: Florian Meier <florian.meier@koalo.de>
|
|
Date: Mon, 25 Jan 2016 15:48:59 +0000
|
|
Subject: [PATCH] ASoC: Add support for Rpi-DAC
|
|
|
|
---
|
|
sound/soc/codecs/Kconfig | 5 +++
|
|
sound/soc/codecs/Makefile | 2 ++
|
|
sound/soc/codecs/pcm1794a.c | 69 +++++++++++++++++++++++++++++++++++++
|
|
3 files changed, 76 insertions(+)
|
|
create mode 100644 sound/soc/codecs/pcm1794a.c
|
|
|
|
--- a/sound/soc/codecs/Kconfig
|
|
+++ b/sound/soc/codecs/Kconfig
|
|
@@ -134,6 +134,7 @@ config SND_SOC_ALL_CODECS
|
|
select SND_SOC_PCM179X_SPI if SPI_MASTER
|
|
select SND_SOC_PCM186X_I2C if I2C
|
|
select SND_SOC_PCM186X_SPI if SPI_MASTER
|
|
+ select SND_SOC_PCM1794A if I2C
|
|
select SND_SOC_PCM3008
|
|
select SND_SOC_PCM3060_I2C if I2C
|
|
select SND_SOC_PCM3060_SPI if SPI_MASTER
|
|
@@ -980,6 +981,10 @@ config SND_SOC_RT5616
|
|
tristate "Realtek RT5616 CODEC"
|
|
depends on I2C
|
|
|
|
+config SND_SOC_PCM1794A
|
|
+ tristate
|
|
+ depends on I2C
|
|
+
|
|
config SND_SOC_RT5631
|
|
tristate "Realtek ALC5631/RT5631 CODEC"
|
|
depends on I2C
|
|
--- a/sound/soc/codecs/Makefile
|
|
+++ b/sound/soc/codecs/Makefile
|
|
@@ -134,6 +134,7 @@ snd-soc-pcm179x-spi-objs := pcm179x-spi.
|
|
snd-soc-pcm186x-objs := pcm186x.o
|
|
snd-soc-pcm186x-i2c-objs := pcm186x-i2c.o
|
|
snd-soc-pcm186x-spi-objs := pcm186x-spi.o
|
|
+snd-soc-pcm1794a-objs := pcm1794a.o
|
|
snd-soc-pcm3008-objs := pcm3008.o
|
|
snd-soc-pcm3060-objs := pcm3060.o
|
|
snd-soc-pcm3060-i2c-objs := pcm3060-i2c.o
|
|
@@ -430,6 +431,7 @@ obj-$(CONFIG_SND_SOC_PCM512x) += snd-soc
|
|
obj-$(CONFIG_SND_SOC_PCM512x_I2C) += snd-soc-pcm512x-i2c.o
|
|
obj-$(CONFIG_SND_SOC_PCM512x_SPI) += snd-soc-pcm512x-spi.o
|
|
obj-$(CONFIG_SND_SOC_RK3328) += snd-soc-rk3328.o
|
|
+obj-$(CONFIG_SND_SOC_PCM1794A) += snd-soc-pcm1794a.o
|
|
obj-$(CONFIG_SND_SOC_RL6231) += snd-soc-rl6231.o
|
|
obj-$(CONFIG_SND_SOC_RL6347A) += snd-soc-rl6347a.o
|
|
obj-$(CONFIG_SND_SOC_RT1011) += snd-soc-rt1011.o
|
|
--- /dev/null
|
|
+++ b/sound/soc/codecs/pcm1794a.c
|
|
@@ -0,0 +1,69 @@
|
|
+/*
|
|
+ * Driver for the PCM1794A codec
|
|
+ *
|
|
+ * Author: Florian Meier <florian.meier@koalo.de>
|
|
+ * Copyright 2013
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or
|
|
+ * modify it under the terms of the GNU General Public License
|
|
+ * version 2 as published by the Free Software Foundation.
|
|
+ *
|
|
+ * This program is distributed in the hope that it will be useful, but
|
|
+ * WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ * General Public License for more details.
|
|
+ */
|
|
+
|
|
+
|
|
+#include <linux/init.h>
|
|
+#include <linux/module.h>
|
|
+#include <linux/platform_device.h>
|
|
+
|
|
+#include <sound/soc.h>
|
|
+
|
|
+static struct snd_soc_dai_driver pcm1794a_dai = {
|
|
+ .name = "pcm1794a-hifi",
|
|
+ .playback = {
|
|
+ .channels_min = 2,
|
|
+ .channels_max = 2,
|
|
+ .rates = SNDRV_PCM_RATE_8000_192000,
|
|
+ .formats = SNDRV_PCM_FMTBIT_S16_LE |
|
|
+ SNDRV_PCM_FMTBIT_S24_LE
|
|
+ },
|
|
+};
|
|
+
|
|
+static struct snd_soc_component_driver soc_component_dev_pcm1794a;
|
|
+
|
|
+static int pcm1794a_probe(struct platform_device *pdev)
|
|
+{
|
|
+ return snd_soc_register_component(&pdev->dev, &soc_component_dev_pcm1794a,
|
|
+ &pcm1794a_dai, 1);
|
|
+}
|
|
+
|
|
+static int pcm1794a_remove(struct platform_device *pdev)
|
|
+{
|
|
+ snd_soc_unregister_component(&pdev->dev);
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+static const struct of_device_id pcm1794a_of_match[] = {
|
|
+ { .compatible = "ti,pcm1794a", },
|
|
+ { }
|
|
+};
|
|
+MODULE_DEVICE_TABLE(of, pcm1794a_of_match);
|
|
+
|
|
+static struct platform_driver pcm1794a_component_driver = {
|
|
+ .probe = pcm1794a_probe,
|
|
+ .remove = pcm1794a_remove,
|
|
+ .driver = {
|
|
+ .name = "pcm1794a-codec",
|
|
+ .owner = THIS_MODULE,
|
|
+ .of_match_table = of_match_ptr(pcm1794a_of_match),
|
|
+ },
|
|
+};
|
|
+
|
|
+module_platform_driver(pcm1794a_component_driver);
|
|
+
|
|
+MODULE_DESCRIPTION("ASoC PCM1794A codec driver");
|
|
+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
|
|
+MODULE_LICENSE("GPL v2");
|