mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
95f089dafe
This patch refresh all patches in patches-5.10/ to adjust for Kernel 5.10. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
26 lines
763 B
Diff
26 lines
763 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -324,6 +324,12 @@ config REALTEK_PHY
|
|
help
|
|
Supports the Realtek 821x PHY.
|
|
|
|
+config REALTEK_SOC_PHY
|
|
+ tristate "Realtek SoC PHYs"
|
|
+ depends on RTL838X
|
|
+ help
|
|
+ Supports the PHYs found in combination with Realtek Switch SoCs
|
|
+
|
|
config RENESAS_PHY
|
|
tristate "Renesas PHYs"
|
|
help
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -86,6 +86,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
|
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_REALTEK_SOC_PHY) += rtl83xx-phy.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|