mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
99 lines
2.8 KiB
Diff
99 lines
2.8 KiB
Diff
From 0bccc3722bdd88e8ae995e77ef9f7b77ee4cbdee Mon Sep 17 00:00:00 2001
|
|
From: Daniel Golle <daniel@makrotopia.org>
|
|
Date: Wed, 7 Apr 2021 22:45:54 +0100
|
|
Subject: [PATCH 2/2] mtd: blktrans: call add disks after mtd device
|
|
To: linux-mtd@lists.infradead.org
|
|
Cc: Vignesh Raghavendra <vigneshr@ti.com>,
|
|
Richard Weinberger <richard@nod.at>,
|
|
Miquel Raynal <miquel.raynal@bootlin.com>,
|
|
David Woodhouse <dwmw2@infradead.org>
|
|
|
|
Calling device_add_disk while holding mtd_table_mutex leads
|
|
to deadlock in case part_bits!=0 as block partition parsers
|
|
will try to open the newly created disks, trying to acquire
|
|
mutex once again.
|
|
Move device_add_disk to additional function called after
|
|
add partitions of an MTD device have been added and locks
|
|
have been released.
|
|
|
|
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|
---
|
|
drivers/mtd/mtd_blkdevs.c | 33 ++++++++++++++++++++++++++-------
|
|
drivers/mtd/mtdcore.c | 3 +++
|
|
include/linux/mtd/blktrans.h | 1 +
|
|
3 files changed, 30 insertions(+), 7 deletions(-)
|
|
|
|
--- a/drivers/mtd/mtd_blkdevs.c
|
|
+++ b/drivers/mtd/mtd_blkdevs.c
|
|
@@ -384,13 +384,6 @@ int add_mtd_blktrans_dev(struct mtd_blkt
|
|
if (new->readonly)
|
|
set_disk_ro(gd, 1);
|
|
|
|
- device_add_disk(&new->mtd->dev, gd, NULL);
|
|
-
|
|
- if (new->disk_attributes) {
|
|
- ret = sysfs_create_group(&disk_to_dev(gd)->kobj,
|
|
- new->disk_attributes);
|
|
- WARN_ON(ret);
|
|
- }
|
|
return 0;
|
|
|
|
out_free_tag_set:
|
|
@@ -402,6 +395,27 @@ out_list_del:
|
|
return ret;
|
|
}
|
|
|
|
+void register_mtd_blktrans_devs(void)
|
|
+{
|
|
+ struct mtd_blktrans_ops *tr;
|
|
+ struct mtd_blktrans_dev *dev, *next;
|
|
+ int ret;
|
|
+
|
|
+ list_for_each_entry(tr, &blktrans_majors, list) {
|
|
+ list_for_each_entry_safe(dev, next, &tr->devs, list) {
|
|
+ if (disk_live(dev->disk))
|
|
+ continue;
|
|
+
|
|
+ device_add_disk(&dev->mtd->dev, dev->disk, NULL);
|
|
+ if (dev->disk_attributes) {
|
|
+ ret = sysfs_create_group(&disk_to_dev(dev->disk)->kobj,
|
|
+ dev->disk_attributes);
|
|
+ WARN_ON(ret);
|
|
+ }
|
|
+ }
|
|
+ }
|
|
+}
|
|
+
|
|
int del_mtd_blktrans_dev(struct mtd_blktrans_dev *old)
|
|
{
|
|
unsigned long flags;
|
|
--- a/drivers/mtd/mtdcore.c
|
|
+++ b/drivers/mtd/mtdcore.c
|
|
@@ -32,6 +32,7 @@
|
|
|
|
#include <linux/mtd/mtd.h>
|
|
#include <linux/mtd/partitions.h>
|
|
+#include <linux/mtd/blktrans.h>
|
|
|
|
#include "mtdcore.h"
|
|
|
|
@@ -1081,6 +1082,8 @@ int mtd_device_parse_register(struct mtd
|
|
|
|
ret = mtd_otp_nvmem_add(mtd);
|
|
|
|
+ register_mtd_blktrans_devs();
|
|
+
|
|
out:
|
|
if (ret && device_is_registered(&mtd->dev))
|
|
del_mtd_device(mtd);
|
|
--- a/include/linux/mtd/blktrans.h
|
|
+++ b/include/linux/mtd/blktrans.h
|
|
@@ -76,6 +76,7 @@ extern int deregister_mtd_blktrans(struc
|
|
extern int add_mtd_blktrans_dev(struct mtd_blktrans_dev *dev);
|
|
extern int del_mtd_blktrans_dev(struct mtd_blktrans_dev *dev);
|
|
extern int mtd_blktrans_cease_background(struct mtd_blktrans_dev *dev);
|
|
+extern void register_mtd_blktrans_devs(void);
|
|
|
|
/**
|
|
* module_mtd_blktrans() - Helper macro for registering a mtd blktrans driver
|