mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-09 22:42:57 +00:00
957f1ee85e
Currently, SSDK is rather special in the sense that its not being built as a proper out of tree module at all but rather like a userspace application and that involves a lot of make magic which unfortunately broke with make version 4.4 and newer. Luckily QCA finally added a way to build SSDK as an out of tree module and it uses the kernel buildsystem which makes it compile with make 4.4 as well. So lets backport the support for it and switch to using it. Signed-off-by: Robert Marko <robimarko@gmail.com>
28 lines
994 B
Diff
28 lines
994 B
Diff
From 3026f89b06049df01d5fe19c5fccc972637aa344 Mon Sep 17 00:00:00 2001
|
|
From: crao <quic_crao@quicinc.com>
|
|
Date: Tue, 7 Mar 2023 17:15:07 +0800
|
|
Subject: [PATCH] [qca-ssdk]: fix compilation issue in Linux-Style Makefile
|
|
|
|
Change-Id: If38251fc0a2bf4abc666d30f4812c0d9507310dc
|
|
Signed-off-by: crao <quic_crao@quicinc.com>
|
|
---
|
|
Makefile | 6 +++---
|
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
mode change 100644 => 100755 Makefile
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -27,9 +27,9 @@ all: $(BIN_DIR) kslib
|
|
# LNX Modules-Style Makefile
|
|
####################################################################
|
|
modules: $(BIN_DIR) kslib_c
|
|
- cp Makefile.modules ./Makefile;
|
|
- make -C $(SYS_PATH) M=$(PRJ_PATH)/ $(LNX_MAKEOPTS) modules
|
|
- cp *.ko build/bin;
|
|
+ mkdir -p ./temp/;cp * ./temp -a;cd ./temp;cp ../Makefile.modules ./Makefile;
|
|
+ make -C $(SYS_PATH) M=$(PRJ_PATH)/temp $(LNX_MAKEOPTS) modules
|
|
+ cp temp/*.ko build/bin;
|
|
@echo "---Build [SSDK-$(VERSION)] at $(BUILD_DATE) finished."
|
|
|
|
kslib_c:
|