mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
638ebd3067
Release Notes: https://lwn.net/Articles/923952/ Refresh patches: - 110-darwin_fixes.patch - 115-add-config-xtlibdir.patch - 140-allow_pfifo_fast.patch - 140-keep_libmnl_optional.patch - 145-keep_libelf_optional.patch - 150-keep_libcap_optional.patch - 155-keep_tirpc_optional.patch - 170-ip_tiny.patch - 175-reduce-dynamic-syms.patch - 180-drop_FAILED_POLICY.patch - 190-fix-nls-rpath-link.patch - 195-build_variant_ip_tc.patch - 200-drop_libbsd_dependency.patch - 300-selinux-configurable.patch Remove upstreamed: - 320-configure-Remove-include-sys-stat.h.patch While working on it remove AUTORELEASE. Signed-off-by: Nick Hainke <vincent@systemli.org>
109 lines
3.4 KiB
Diff
109 lines
3.4 KiB
Diff
--- a/ip/Makefile
|
|
+++ b/ip/Makefile
|
|
@@ -19,6 +19,13 @@ RTMONOBJ=rtmon.o
|
|
|
|
include ../config.mk
|
|
|
|
+STATIC_SYM_FILTER:=
|
|
+ifeq ($(IP_CONFIG_TINY),y)
|
|
+ STATIC_SYM_FILTER:=iplink_can.c iplink_ipoib.c iplink_vxlan.c
|
|
+ CFLAGS += -DIPROUTE2_TINY
|
|
+endif
|
|
+STATIC_SYM_SOURCES:=$(filter-out $(STATIC_SYM_FILTER),$(wildcard *.c))
|
|
+
|
|
ALLOBJ=$(IPOBJ) $(RTMONOBJ)
|
|
SCRIPTS=routel
|
|
TARGETS=ip rtmon
|
|
@@ -48,7 +55,7 @@ else
|
|
|
|
ip: static-syms.o
|
|
static-syms.o: static-syms.h
|
|
-static-syms.h: $(wildcard *.c)
|
|
+static-syms.h: $(STATIC_SYM_SOURCES)
|
|
files="$^" ; \
|
|
for s in `grep -B 3 '\<dlsym' $$files | sed -n '/snprintf/{s:.*"\([^"]*\)".*:\1:;s:%s::;p}'` ; do \
|
|
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
|
|
--- a/ip/ip.c
|
|
+++ b/ip/ip.c
|
|
@@ -61,11 +61,17 @@ static void usage(void)
|
|
fprintf(stderr,
|
|
"Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
|
|
" ip [ -force ] -batch filename\n"
|
|
+#ifndef IPROUTE2_TINY
|
|
"where OBJECT := { address | addrlabel | amt | fou | help | ila | ioam | l2tp |\n"
|
|
" link | macsec | maddress | monitor | mptcp | mroute | mrule |\n"
|
|
" neighbor | neighbour | netconf | netns | nexthop | ntable |\n"
|
|
" ntbl | route | rule | sr | tap | tcpmetrics |\n"
|
|
" token | tunnel | tuntap | vrf | xfrm }\n"
|
|
+#else
|
|
+ "where OBJECT := { address | link | maddress | monitor |\n"
|
|
+ " neighbor | neighbour | netns | route |\n"
|
|
+ " rule | token | tunnel }\n"
|
|
+#endif
|
|
" OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
|
|
" -h[uman-readable] | -iec | -j[son] | -p[retty] |\n"
|
|
" -f[amily] { inet | inet6 | mpls | bridge | link } |\n"
|
|
@@ -88,37 +94,49 @@ static const struct cmd {
|
|
int (*func)(int argc, char **argv);
|
|
} cmds[] = {
|
|
{ "address", do_ipaddr },
|
|
+#ifndef IPROUTE2_TINY
|
|
{ "addrlabel", do_ipaddrlabel },
|
|
+#endif
|
|
{ "maddress", do_multiaddr },
|
|
{ "route", do_iproute },
|
|
{ "rule", do_iprule },
|
|
{ "neighbor", do_ipneigh },
|
|
{ "neighbour", do_ipneigh },
|
|
+#ifndef IPROUTE2_TINY
|
|
{ "ntable", do_ipntable },
|
|
{ "ntbl", do_ipntable },
|
|
+#endif
|
|
{ "link", do_iplink },
|
|
+#ifndef IPROUTE2_TINY
|
|
{ "l2tp", do_ipl2tp },
|
|
{ "fou", do_ipfou },
|
|
{ "ila", do_ipila },
|
|
{ "macsec", do_ipmacsec },
|
|
+#endif
|
|
{ "tunnel", do_iptunnel },
|
|
{ "tunl", do_iptunnel },
|
|
+#ifndef IPROUTE2_TINY
|
|
{ "tuntap", do_iptuntap },
|
|
{ "tap", do_iptuntap },
|
|
{ "token", do_iptoken },
|
|
{ "tcpmetrics", do_tcp_metrics },
|
|
{ "tcp_metrics", do_tcp_metrics },
|
|
+#endif
|
|
{ "monitor", do_ipmonitor },
|
|
+#ifndef IPROUTE2_TINY
|
|
{ "xfrm", do_xfrm },
|
|
{ "mroute", do_multiroute },
|
|
{ "mrule", do_multirule },
|
|
+#endif
|
|
{ "netns", do_netns },
|
|
+#ifndef IPROUTE2_TINY
|
|
{ "netconf", do_ipnetconf },
|
|
{ "vrf", do_ipvrf},
|
|
{ "sr", do_seg6 },
|
|
{ "nexthop", do_ipnh },
|
|
{ "mptcp", do_mptcp },
|
|
{ "ioam", do_ioam6 },
|
|
+#endif
|
|
{ "help", do_help },
|
|
{ "stats", do_ipstats },
|
|
{ 0 }
|
|
--- a/lib/Makefile
|
|
+++ b/lib/Makefile
|
|
@@ -3,6 +3,10 @@ include ../config.mk
|
|
|
|
CFLAGS += $(FPIC)
|
|
|
|
+ifeq ($(IP_CONFIG_TINY),y)
|
|
+ CFLAGS += -DIPROUTE2_TINY
|
|
+endif
|
|
+
|
|
UTILOBJ = utils.o utils_math.o rt_names.o ll_map.o ll_types.o ll_proto.o ll_addr.o \
|
|
inet_proto.o namespace.o json_writer.o json_print.o json_print_math.o \
|
|
names.o color.o bpf_legacy.o bpf_glue.o exec.o fs.o cg_map.o ppp_proto.o
|