mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
050621aa01
This patch adds a new spi-nand driver which implements the SNFI of mt7622 and mt7629. Unlike the existing snfi driver which makes use of the spi-mem framework and the spi-nand framework with modified ecc support, this driver is implemented directly on the mtd framework with other components untouched, and provides better performance, and behaves exactly the same as the nand framework. Signed-off-by: Weijie Gao <hackpascal@gmail.com>
22 lines
539 B
Diff
22 lines
539 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -238,6 +238,8 @@ source "drivers/mtd/ubi/Kconfig"
|
|
|
|
source "drivers/mtd/hyperbus/Kconfig"
|
|
|
|
+source "drivers/mtd/mtk-snand/Kconfig"
|
|
+
|
|
source "drivers/mtd/composite/Kconfig"
|
|
|
|
endif # MTD
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -34,5 +34,7 @@ obj-$(CONFIG_MTD_SPI_NOR) += spi-nor/
|
|
obj-$(CONFIG_MTD_UBI) += ubi/
|
|
obj-$(CONFIG_MTD_HYPERBUS) += hyperbus/
|
|
|
|
+obj-$(CONFIG_MTK_SPI_NAND) += mtk-snand/
|
|
+
|
|
# Composite drivers must be loaded last
|
|
obj-y += composite/
|