mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 21:58:04 +00:00
9a673642a2
Refresh hack patches with make target/linux/refresh. Signed-off-by: Weijie Gao <hackpascal@gmail.com>
103 lines
3.2 KiB
Diff
103 lines
3.2 KiB
Diff
From b14784e7883390c20ed3ff904892255404a5914b Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Fri, 7 Jul 2017 17:05:53 +0200
|
|
Subject: add an optional config option for stripping all unnecessary symbol exports from the kernel image
|
|
|
|
lede-commit: bb5a40c64b7c4f4848509fa0a6625055fc9e66cc
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
include/asm-generic/vmlinux.lds.h | 18 +++++++++++++++---
|
|
include/linux/export.h | 9 ++++++++-
|
|
scripts/Makefile.build | 2 +-
|
|
3 files changed, 24 insertions(+), 5 deletions(-)
|
|
|
|
--- a/include/asm-generic/vmlinux.lds.h
|
|
+++ b/include/asm-generic/vmlinux.lds.h
|
|
@@ -81,6 +81,16 @@
|
|
#define RO_EXCEPTION_TABLE
|
|
#endif
|
|
|
|
+#ifndef SYMTAB_KEEP
|
|
+#define SYMTAB_KEEP KEEP(*(SORT(___ksymtab+*)))
|
|
+#define SYMTAB_KEEP_GPL KEEP(*(SORT(___ksymtab_gpl+*)))
|
|
+#endif
|
|
+
|
|
+#ifndef SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD_GPL
|
|
+#endif
|
|
+
|
|
/* Align . function alignment. */
|
|
#define ALIGN_FUNCTION() . = ALIGN(CONFIG_FUNCTION_ALIGNMENT)
|
|
|
|
@@ -486,14 +496,14 @@
|
|
/* Kernel symbol table: Normal symbols */ \
|
|
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \
|
|
__start___ksymtab = .; \
|
|
- KEEP(*(SORT(___ksymtab+*))) \
|
|
+ SYMTAB_KEEP \
|
|
__stop___ksymtab = .; \
|
|
} \
|
|
\
|
|
/* Kernel symbol table: GPL-only symbols */ \
|
|
__ksymtab_gpl : AT(ADDR(__ksymtab_gpl) - LOAD_OFFSET) { \
|
|
__start___ksymtab_gpl = .; \
|
|
- KEEP(*(SORT(___ksymtab_gpl+*))) \
|
|
+ SYMTAB_KEEP_GPL \
|
|
__stop___ksymtab_gpl = .; \
|
|
} \
|
|
\
|
|
@@ -513,7 +523,7 @@
|
|
\
|
|
/* Kernel symbol table: strings */ \
|
|
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \
|
|
- *(__ksymtab_strings) \
|
|
+ *(__ksymtab_strings+*) \
|
|
} \
|
|
\
|
|
/* __*init sections */ \
|
|
@@ -1000,6 +1010,8 @@
|
|
#define COMMON_DISCARDS \
|
|
SANITIZER_DISCARDS \
|
|
PATCHABLE_DISCARDS \
|
|
+ SYMTAB_DISCARD \
|
|
+ SYMTAB_DISCARD_GPL \
|
|
*(.discard) \
|
|
*(.discard.*) \
|
|
*(.export_symbol) \
|
|
--- a/include/linux/export-internal.h
|
|
+++ b/include/linux/export-internal.h
|
|
@@ -26,6 +26,12 @@
|
|
#define __KSYM_REF(sym) ".long " #sym
|
|
#endif
|
|
|
|
+#ifdef MODULE
|
|
+#define __EXPORT_SUFFIX(sym)
|
|
+#else
|
|
+#define __EXPORT_SUFFIX(sym) "+" #sym
|
|
+#endif
|
|
+
|
|
/*
|
|
* For every exported symbol, do the following:
|
|
*
|
|
@@ -38,7 +44,7 @@
|
|
* former apparently works on all arches according to the binutils source.
|
|
*/
|
|
#define __KSYMTAB(name, sym, sec, ns) \
|
|
- asm(" .section \"__ksymtab_strings\",\"aMS\",%progbits,1" "\n" \
|
|
+ asm(" .section \"__ksymtab_strings" __EXPORT_SUFFIX(sym) "\",\"aMS\",%progbits,1" "\n" \
|
|
"__kstrtab_" #name ":" "\n" \
|
|
" .asciz \"" #name "\"" "\n" \
|
|
"__kstrtabns_" #name ":" "\n" \
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -366,7 +366,7 @@ targets += $(real-dtb-y) $(lib-y) $(alwa
|
|
# Linker scripts preprocessor (.lds.S -> .lds)
|
|
# ---------------------------------------------------------------------------
|
|
quiet_cmd_cpp_lds_S = LDS $@
|
|
- cmd_cpp_lds_S = $(CPP) $(cpp_flags) -P -U$(ARCH) \
|
|
+ cmd_cpp_lds_S = $(CPP) $(EXTRA_LDSFLAGS) $(cpp_flags) -P -U$(ARCH) \
|
|
-D__ASSEMBLY__ -DLINKER_SCRIPT -o $@ $<
|
|
|
|
$(obj)/%.lds: $(src)/%.lds.S FORCE
|