mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 21:58:04 +00:00
99545b4bb1
This target adds support for the Allwinner D1 RISC-V based SoCs. - RISC-V single-core T-Head C906 (RV64GCV) - Tensilica HiFi4 DSP - DDR2/DDR3 support - 10/100/1000M ethernet - usual peripherals like USB2, SPI, I2C, PWM, etc. Four boards are supported: - Dongshan Nezha STU - 512Mb RAM - ethernet - LicheePi RV Dock - 512Mb RAM - wireless-only (RTL8723DS) - MangoPi MQ-Pro - 512Mb RAM - there are pads available for an SPI flash - wireless-only (RTL8723DS) - Nezha D1 - 512Mb/1Gb/2Gb RAM - 256Mb NAND flash - ethernet, wireless Installation: Standard SD-card installation via dd-ing the generated image to an SD-card of at least 256Mb. Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
160 lines
4.0 KiB
Diff
160 lines
4.0 KiB
Diff
From 3cf55c25453517960d72b56d1ba8f12840b1990e Mon Sep 17 00:00:00 2001
|
|
From: Samuel Holland <samuel@sholland.org>
|
|
Date: Sat, 9 Jul 2022 17:43:17 -0500
|
|
Subject: [PATCH 031/117] riscv: dts: allwinner: Add MangoPi MQ Pro devicetree
|
|
|
|
The MangoPi MQ Pro is a tiny SBC with a layout compatible to the
|
|
Raspberry Pi Zero. It includes the Allwinner D1 SoC, 512M or 1G of DDR3,
|
|
and an RTL8723DS-based WiFi/Bluetooth module.
|
|
|
|
The board also exposes GPIO Port E via a connector on the end of the
|
|
board, which can support either a camera or an RMII Ethernet PHY. The
|
|
additional regulators supply that connector.
|
|
|
|
Signed-off-by: Samuel Holland <samuel@sholland.org>
|
|
---
|
|
arch/riscv/boot/dts/allwinner/Makefile | 1 +
|
|
.../allwinner/sun20i-d1-mangopi-mq-pro.dts | 128 ++++++++++++++++++
|
|
2 files changed, 129 insertions(+)
|
|
create mode 100644 arch/riscv/boot/dts/allwinner/sun20i-d1-mangopi-mq-pro.dts
|
|
|
|
--- a/arch/riscv/boot/dts/allwinner/Makefile
|
|
+++ b/arch/riscv/boot/dts/allwinner/Makefile
|
|
@@ -3,4 +3,5 @@ dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-li
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv-86-panel-720p.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv-dock.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-lichee-rv.dtb
|
|
+dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-mangopi-mq-pro.dtb
|
|
dtb-$(CONFIG_ARCH_SUNXI) += sun20i-d1-nezha.dtb
|
|
--- /dev/null
|
|
+++ b/arch/riscv/boot/dts/allwinner/sun20i-d1-mangopi-mq-pro.dts
|
|
@@ -0,0 +1,128 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0+ or MIT)
|
|
+// Copyright (C) 2022 Samuel Holland <samuel@sholland.org>
|
|
+
|
|
+/dts-v1/;
|
|
+
|
|
+#include <dt-bindings/gpio/gpio.h>
|
|
+
|
|
+#include "sun20i-d1.dtsi"
|
|
+#include "sun20i-d1-common-regulators.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "MangoPi MQ Pro";
|
|
+ compatible = "widora,mangopi-mq-pro", "allwinner,sun20i-d1";
|
|
+
|
|
+ aliases {
|
|
+ ethernet0 = &rtl8723ds;
|
|
+ mmc0 = &mmc0;
|
|
+ serial0 = &uart0;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ stdout-path = "serial0:115200n8";
|
|
+ };
|
|
+
|
|
+ reg_avdd2v8: avdd2v8 {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "avdd2v8";
|
|
+ regulator-min-microvolt = <2800000>;
|
|
+ regulator-max-microvolt = <2800000>;
|
|
+ vin-supply = <®_vcc_3v3>;
|
|
+ };
|
|
+
|
|
+ reg_dvdd: dvdd {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "dvdd";
|
|
+ regulator-min-microvolt = <1200000>;
|
|
+ regulator-max-microvolt = <1200000>;
|
|
+ vin-supply = <®_vcc_3v3>;
|
|
+ };
|
|
+
|
|
+ reg_vdd_cpu: vdd-cpu {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "vdd-cpu";
|
|
+ regulator-min-microvolt = <1100000>;
|
|
+ regulator-max-microvolt = <1100000>;
|
|
+ vin-supply = <®_vcc>;
|
|
+ };
|
|
+
|
|
+ wifi_pwrseq: wifi-pwrseq {
|
|
+ compatible = "mmc-pwrseq-simple";
|
|
+ reset-gpios = <&pio 6 17 GPIO_ACTIVE_LOW>; /* PG17 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&cpu0 {
|
|
+ cpu-supply = <®_vdd_cpu>;
|
|
+};
|
|
+
|
|
+&ehci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc0 {
|
|
+ bus-width = <4>;
|
|
+ cd-gpios = <&pio 5 6 GPIO_ACTIVE_HIGH>; /* PF6 */
|
|
+ disable-wp;
|
|
+ vmmc-supply = <®_vcc_3v3>;
|
|
+ vqmmc-supply = <®_vcc_3v3>;
|
|
+ pinctrl-0 = <&mmc0_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&mmc1 {
|
|
+ bus-width = <4>;
|
|
+ mmc-pwrseq = <&wifi_pwrseq>;
|
|
+ non-removable;
|
|
+ vmmc-supply = <®_vcc_3v3>;
|
|
+ vqmmc-supply = <®_vcc_3v3>;
|
|
+ pinctrl-0 = <&mmc1_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ rtl8723ds: wifi@1 {
|
|
+ reg = <1>;
|
|
+ interrupt-parent = <&pio>;
|
|
+ interrupts = <6 10 IRQ_TYPE_LEVEL_LOW>; /* PG10 */
|
|
+ interrupt-names = "host-wake";
|
|
+ };
|
|
+};
|
|
+
|
|
+&ohci1 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&pio {
|
|
+ vcc-pe-supply = <®_avdd2v8>;
|
|
+};
|
|
+
|
|
+&uart0 {
|
|
+ pinctrl-0 = <&uart0_pb8_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&uart1 {
|
|
+ uart-has-rtscts;
|
|
+ pinctrl-0 = <&uart1_pg6_pins>, <&uart1_pg8_rts_cts_pins>;
|
|
+ pinctrl-names = "default";
|
|
+ status = "okay";
|
|
+
|
|
+ bluetooth {
|
|
+ compatible = "realtek,rtl8723ds-bt";
|
|
+ device-wake-gpios = <&pio 6 18 GPIO_ACTIVE_HIGH>; /* PG18 */
|
|
+ enable-gpios = <&pio 6 15 GPIO_ACTIVE_HIGH>; /* PG15 */
|
|
+ host-wake-gpios = <&pio 6 14 GPIO_ACTIVE_HIGH>; /* PG14 */
|
|
+ };
|
|
+};
|
|
+
|
|
+&usb_otg {
|
|
+ dr_mode = "peripheral";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usbphy {
|
|
+ usb0_vbus-supply = <®_vcc>;
|
|
+ status = "okay";
|
|
+};
|