mirror of
https://github.com/openwrt/openwrt.git
synced 2025-02-02 01:08:05 +00:00
09d95e44fc
mbedtls changed in version 2.7.0 and 2.7.2 the soversion of the libmbedcrypto.so library, use the old version again to be able to use the new library with binaries compiled against the old mbedtls library. Some binaries got rebuild to for the 2.7.0 release and are now using libmbedcrypto.so.1, the older ones are still using libmbedcrypto.so.0. Go back to libmbedcrypto.so.0 and make the system rebuild the binaries which were rebuild for 2.7.0 again. This should make the libmbedcrypto.so library be compatible with the old version shipped with 17.01. Fixes: 3ca1438ae0 ("mbedtls: update to version 2.7.2") Fixes: f609913b5c ("mbedtls: update to version 2.7.0") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
27 lines
831 B
Diff
27 lines
831 B
Diff
mbedtls changed in version 2.7.0 and 2.7.2 the soversion of the
|
|
libmbedcrypto.so library, use the old version again to be able to use
|
|
the new library with binaries compiled against the old library.
|
|
|
|
--- a/library/CMakeLists.txt
|
|
+++ b/library/CMakeLists.txt
|
|
@@ -141,7 +141,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
|
|
|
|
if(USE_SHARED_MBEDTLS_LIBRARY)
|
|
add_library(mbedcrypto SHARED ${src_crypto})
|
|
- set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.2 SOVERSION 2)
|
|
+ set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.2 SOVERSION 0)
|
|
target_link_libraries(mbedcrypto ${libs})
|
|
|
|
add_library(mbedx509 SHARED ${src_x509})
|
|
--- a/library/Makefile
|
|
+++ b/library/Makefile
|
|
@@ -33,7 +33,7 @@ endif
|
|
|
|
SOEXT_TLS=so.10
|
|
SOEXT_X509=so.0
|
|
-SOEXT_CRYPTO=so.2
|
|
+SOEXT_CRYPTO=so.0
|
|
|
|
DLEXT=so
|
|
# OSX shared library extension:
|