mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
7d7aa2fd92
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
82 lines
2.0 KiB
Diff
82 lines
2.0 KiB
Diff
From 28b591dadb504861cdc535d5705aa4c8c3d3420f Mon Sep 17 00:00:00 2001
|
|
From: popcornmix <popcornmix@gmail.com>
|
|
Date: Fri, 30 Nov 2018 18:55:23 +0000
|
|
Subject: [PATCH] lirc-rpi: Remove in favour of gpio-ir
|
|
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 -
|
|
.../boot/dts/overlays/lirc-rpi-overlay.dts | 57 -------------------
|
|
2 files changed, 58 deletions(-)
|
|
delete mode 100644 arch/arm/boot/dts/overlays/lirc-rpi-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -68,7 +68,6 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
jedec-spi-nor.dtbo \
|
|
justboom-dac.dtbo \
|
|
justboom-digi.dtbo \
|
|
- lirc-rpi.dtbo \
|
|
ltc294x.dtbo \
|
|
mbed-dac.dtbo \
|
|
mcp23017.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/lirc-rpi-overlay.dts
|
|
+++ /dev/null
|
|
@@ -1,57 +0,0 @@
|
|
-// Definitions for lirc-rpi module
|
|
-/dts-v1/;
|
|
-/plugin/;
|
|
-
|
|
-/ {
|
|
- compatible = "brcm,bcm2708";
|
|
-
|
|
- fragment@0 {
|
|
- target-path = "/";
|
|
- __overlay__ {
|
|
- lirc_rpi: lirc_rpi {
|
|
- compatible = "rpi,lirc-rpi";
|
|
- pinctrl-names = "default";
|
|
- pinctrl-0 = <&lirc_pins>;
|
|
- status = "okay";
|
|
-
|
|
- // Override autodetection of IR receiver circuit
|
|
- // (0 = active high, 1 = active low, -1 = no override )
|
|
- rpi,sense = <0xffffffff>;
|
|
-
|
|
- // Software carrier
|
|
- // (0 = off, 1 = on)
|
|
- rpi,softcarrier = <1>;
|
|
-
|
|
- // Invert output
|
|
- // (0 = off, 1 = on)
|
|
- rpi,invert = <0>;
|
|
-
|
|
- // Enable debugging messages
|
|
- // (0 = off, 1 = on)
|
|
- rpi,debug = <0>;
|
|
- };
|
|
- };
|
|
- };
|
|
-
|
|
- fragment@1 {
|
|
- target = <&gpio>;
|
|
- __overlay__ {
|
|
- lirc_pins: lirc_pins {
|
|
- brcm,pins = <17 18>;
|
|
- brcm,function = <1 0>; // out in
|
|
- brcm,pull = <0 1>; // off down
|
|
- };
|
|
- };
|
|
- };
|
|
-
|
|
- __overrides__ {
|
|
- gpio_out_pin = <&lirc_pins>,"brcm,pins:0";
|
|
- gpio_in_pin = <&lirc_pins>,"brcm,pins:4";
|
|
- gpio_in_pull = <&lirc_pins>,"brcm,pull:4";
|
|
-
|
|
- sense = <&lirc_rpi>,"rpi,sense:0";
|
|
- softcarrier = <&lirc_rpi>,"rpi,softcarrier:0";
|
|
- invert = <&lirc_rpi>,"rpi,invert:0";
|
|
- debug = <&lirc_rpi>,"rpi,debug:0";
|
|
- };
|
|
-};
|