mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-07 14:28:50 +00:00
5582fbd613
With global NLS support enabled (CONFIG_BUILD_NLS), the linked libelf.so
and libbfd.so libraries will depend on libintl.so. Import the nls.mk helper
to set library prefixes and flags accordingly, and also conditionally add
"-lintl" as link-time library.
Fix a build error on ppc due to a EDEADLOCK redefinition in errno.h.
Use upstream stable kernel 5.8.9, and fix overriding of feature detection
to only allow/hide detected features. Also refresh existing patches.
Fixes: 2f0d672088
("bpftools: add utility and library packages supporting
eBPF usage")
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
From 74d0dcf7608b1bab116e297468ac51b57eb97ce0 Mon Sep 17 00:00:00 2001
|
|
From: Tony Ambardar <Tony.Ambardar@gmail.com>
|
|
Date: Thu, 20 Aug 2020 10:06:24 -0700
|
|
Subject: [PATCH] libbpf: fix build failure from uninitialized variable warning
|
|
|
|
While compiling libbpf, some GCC versions (at least 8.4.0) have difficulty
|
|
determining control flow and a emit warning for potentially uninitialized
|
|
usage of 'map', which results in a build error if using "-Werror":
|
|
|
|
In file included from libbpf.c:56:
|
|
libbpf.c: In function '__bpf_object__open':
|
|
libbpf_internal.h:59:2: warning: 'map' may be used uninitialized in this function [-Wmaybe-uninitialized]
|
|
libbpf_print(level, "libbpf: " fmt, ##__VA_ARGS__); \
|
|
^~~~~~~~~~~~
|
|
libbpf.c:5032:18: note: 'map' was declared here
|
|
struct bpf_map *map, *targ_map;
|
|
^~~
|
|
|
|
The warning/error is false based on code inspection, so silence it with a
|
|
NULL initialization.
|
|
|
|
Fixes: 646f02ffdd49 ("libbpf: Add BTF-defined map-in-map support")
|
|
Ref: 063e68813391 ("libbpf: Fix false uninitialized variable warning")
|
|
|
|
Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
|
|
---
|
|
tools/lib/bpf/libbpf.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
--- a/tools/lib/bpf/libbpf.c
|
|
+++ b/tools/lib/bpf/libbpf.c
|
|
@@ -5030,8 +5030,8 @@ static int bpf_object__collect_map_relos
|
|
int i, j, nrels, new_sz;
|
|
const struct btf_var_secinfo *vi = NULL;
|
|
const struct btf_type *sec, *var, *def;
|
|
+ struct bpf_map *map = NULL, *targ_map;
|
|
const struct btf_member *member;
|
|
- struct bpf_map *map, *targ_map;
|
|
const char *name, *mname;
|
|
Elf_Data *symbols;
|
|
unsigned int moff;
|