mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 17:48:58 +00:00
5acc4f919c
Currently it's needed to have gcc-multilib on the host to correctly compile xdp-tools. This is wrong and means that we are using host header to compile a tool. By some searching in how the makefile works it was discovered that BPF_CFLAGS were not used and required to be appended to config.mk Only one single header was added but we should include each BPF_CFLAGS from bpf.mk. To make this some patching to bpf-header were required and some patches to xdp-tools were required. Also it's needed to pass the correct target to BPF_CFLAGS. With the following changes xdp-tools can correctly compile with each header from bpf-headers and should not use any host header. Co-Developed-by: Andre Heider <a.heider@gmail.com> Signed-off-by: Andre Heider <a.heider@gmail.com> Link: https://github.com/openwrt/openwrt/pull/11825 Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
32 lines
852 B
Diff
32 lines
852 B
Diff
From bc2a11227b5bed29d33926d5ff7e707228db9e87 Mon Sep 17 00:00:00 2001
|
|
From: Christian Marangi <ansuelsmth@gmail.com>
|
|
Date: Wed, 18 Jan 2023 20:07:58 +0100
|
|
Subject: [PATCH] headers: xdp: drop vlan_hdr as already defined
|
|
|
|
Drop vlan_hdr as already defined by bpf headers.
|
|
|
|
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
|
|
---
|
|
headers/xdp/parsing_helpers.h | 10 ----------
|
|
1 file changed, 10 deletions(-)
|
|
|
|
--- a/headers/xdp/parsing_helpers.h
|
|
+++ b/headers/xdp/parsing_helpers.h
|
|
@@ -33,16 +33,6 @@ struct hdr_cursor {
|
|
};
|
|
|
|
/*
|
|
- * struct vlan_hdr - vlan header
|
|
- * @h_vlan_TCI: priority and VLAN ID
|
|
- * @h_vlan_encapsulated_proto: packet type ID or len
|
|
- */
|
|
-struct vlan_hdr {
|
|
- __be16 h_vlan_TCI;
|
|
- __be16 h_vlan_encapsulated_proto;
|
|
-};
|
|
-
|
|
-/*
|
|
* Struct icmphdr_common represents the common part of the icmphdr and icmp6hdr
|
|
* structures.
|
|
*/
|