mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 06:08:08 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
58 lines
1.9 KiB
Diff
58 lines
1.9 KiB
Diff
From c979072887ef70aab2ab6e71544853df71017925 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.com>
|
|
Date: Wed, 12 Jan 2022 08:23:28 +0000
|
|
Subject: [PATCH] spi: gpio: Add sck-idle-input property
|
|
|
|
The sck-idle-input property indicates that the spi-gpio driver should
|
|
return the SCK line to an input when the chip select signals are
|
|
inactive.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.com>
|
|
---
|
|
drivers/spi/spi-gpio.c | 13 +++++++++++--
|
|
1 file changed, 11 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/spi/spi-gpio.c
|
|
+++ b/drivers/spi/spi-gpio.c
|
|
@@ -35,6 +35,7 @@ struct spi_gpio {
|
|
struct gpio_desc *sck;
|
|
struct gpio_desc *miso;
|
|
struct gpio_desc *mosi;
|
|
+ bool sck_idle_input;
|
|
struct gpio_desc **cs_gpios;
|
|
};
|
|
|
|
@@ -201,8 +202,12 @@ static void spi_gpio_chipselect(struct s
|
|
struct spi_gpio *spi_gpio = spi_to_spi_gpio(spi);
|
|
|
|
/* set initial clock line level */
|
|
- if (is_active)
|
|
- gpiod_set_value_cansleep(spi_gpio->sck, spi->mode & SPI_CPOL);
|
|
+ if (is_active) {
|
|
+ if (spi_gpio->sck_idle_input)
|
|
+ gpiod_direction_output(spi_gpio->sck, spi->mode & SPI_CPOL);
|
|
+ else
|
|
+ gpiod_set_value_cansleep(spi_gpio->sck, spi->mode & SPI_CPOL);
|
|
+ }
|
|
|
|
/* Drive chip select line, if we have one */
|
|
if (spi_gpio->cs_gpios) {
|
|
@@ -211,6 +216,9 @@ static void spi_gpio_chipselect(struct s
|
|
/* SPI chip selects are normally active-low */
|
|
gpiod_set_value_cansleep(cs, (spi->mode & SPI_CS_HIGH) ? is_active : !is_active);
|
|
}
|
|
+
|
|
+ if (spi_gpio->sck_idle_input && !is_active)
|
|
+ gpiod_direction_input(spi_gpio->sck);
|
|
}
|
|
|
|
static int spi_gpio_setup(struct spi_device *spi)
|
|
@@ -299,6 +307,7 @@ static int spi_gpio_request(struct devic
|
|
if (IS_ERR(spi_gpio->miso))
|
|
return PTR_ERR(spi_gpio->miso);
|
|
|
|
+ spi_gpio->sck_idle_input = device_property_read_bool(dev, "sck-idle-input");
|
|
spi_gpio->sck = devm_gpiod_get(dev, "sck", GPIOD_OUT_LOW);
|
|
return PTR_ERR_OR_ZERO(spi_gpio->sck);
|
|
}
|