mirror of
https://github.com/openwrt/openwrt.git
synced 2025-01-10 23:12:48 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
97 lines
3.5 KiB
Diff
97 lines
3.5 KiB
Diff
From 12d1b2ed20e6e431ed22b359bc6e13f51f45c2f3 Mon Sep 17 00:00:00 2001
|
|
From: Jonathan Bell <jonathan@raspberrypi.com>
|
|
Date: Wed, 16 Feb 2022 14:31:02 +0000
|
|
Subject: [PATCH] usb: xhci: add a quirk for Superspeed bulk OUT
|
|
transfers on VL805
|
|
|
|
The VL805 has a bug in its internal FIFO space accounting that results
|
|
in bulk OUT babble if a TRB in a large multi-element TD has a data
|
|
buffer size that is larger than and not a multiple of wMaxPacketSize for
|
|
the endpoint. If the downstream USB3.0 link is congested, or latency is
|
|
increased through an intermediate hub, then the VL805 enters a suspected
|
|
FIFO overflow condition and transmits repeated, garbled data to the
|
|
endpoint.
|
|
|
|
TDs with TRBs of exact multiples of wMaxPacketSize and smaller than
|
|
wMaxPacketSize appear to be handled correctly, so split buffers at a
|
|
1024-byte length boundary and put the remainder in a separate smaller
|
|
TRB.
|
|
|
|
Signed-off-by: Jonathan Bell <jonathan@raspberrypi.com>
|
|
---
|
|
drivers/usb/host/xhci-pci.c | 1 +
|
|
drivers/usb/host/xhci-ring.c | 21 +++++++++++++++++++--
|
|
drivers/usb/host/xhci.h | 1 +
|
|
3 files changed, 21 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/usb/host/xhci-pci.c
|
|
+++ b/drivers/usb/host/xhci-pci.c
|
|
@@ -295,6 +295,7 @@ static void xhci_pci_quirks(struct devic
|
|
xhci->quirks |= XHCI_EP_CTX_BROKEN_DCS;
|
|
xhci->quirks |= XHCI_AVOID_DQ_ON_LINK;
|
|
xhci->quirks |= XHCI_VLI_TRB_CACHE_BUG;
|
|
+ xhci->quirks |= XHCI_VLI_SS_BULK_OUT_BUG;
|
|
}
|
|
|
|
if (pdev->vendor == PCI_VENDOR_ID_ASMEDIA &&
|
|
--- a/drivers/usb/host/xhci-ring.c
|
|
+++ b/drivers/usb/host/xhci-ring.c
|
|
@@ -3614,14 +3614,15 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
|
|
unsigned int num_trbs;
|
|
unsigned int start_cycle, num_sgs = 0;
|
|
unsigned int enqd_len, block_len, trb_buff_len, full_len;
|
|
- int sent_len, ret;
|
|
- u32 field, length_field, remainder;
|
|
+ int sent_len, ret, vli_quirk = 0;
|
|
+ u32 field, length_field, remainder, maxpacket;
|
|
u64 addr, send_addr;
|
|
|
|
ring = xhci_urb_to_transfer_ring(xhci, urb);
|
|
if (!ring)
|
|
return -EINVAL;
|
|
|
|
+ maxpacket = usb_endpoint_maxp(&urb->ep->desc);
|
|
full_len = urb->transfer_buffer_length;
|
|
/* If we have scatter/gather list, we use it. */
|
|
if (urb->num_sgs && !(urb->transfer_flags & URB_DMA_MAP_SINGLE)) {
|
|
@@ -3658,6 +3659,17 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
|
|
start_cycle = ring->cycle_state;
|
|
send_addr = addr;
|
|
|
|
+ if (xhci->quirks & XHCI_VLI_SS_BULK_OUT_BUG &&
|
|
+ !usb_urb_dir_in(urb) && urb->dev->speed >= USB_SPEED_SUPER) {
|
|
+ /*
|
|
+ * VL805 - superspeed bulk OUT traffic can cause
|
|
+ * an internal fifo overflow if the TRB buffer is larger
|
|
+ * than wMaxPacket and the length is not an integer
|
|
+ * multiple of wMaxPacket.
|
|
+ */
|
|
+ vli_quirk = 1;
|
|
+ }
|
|
+
|
|
/* Queue the TRBs, even if they are zero-length */
|
|
for (enqd_len = 0; first_trb || enqd_len < full_len;
|
|
enqd_len += trb_buff_len) {
|
|
@@ -3670,6 +3682,11 @@ int xhci_queue_bulk_tx(struct xhci_hcd *
|
|
if (enqd_len + trb_buff_len > full_len)
|
|
trb_buff_len = full_len - enqd_len;
|
|
|
|
+ if (vli_quirk && trb_buff_len > maxpacket) {
|
|
+ /* SS bulk wMaxPacket is 1024B */
|
|
+ remainder = trb_buff_len & (maxpacket - 1);
|
|
+ trb_buff_len -= remainder;
|
|
+ }
|
|
/* Don't change the cycle bit of the first TRB until later */
|
|
if (first_trb) {
|
|
first_trb = false;
|
|
--- a/drivers/usb/host/xhci.h
|
|
+++ b/drivers/usb/host/xhci.h
|
|
@@ -1908,6 +1908,7 @@ struct xhci_hcd {
|
|
#define XHCI_RESET_TO_DEFAULT BIT_ULL(44)
|
|
#define XHCI_AVOID_DQ_ON_LINK BIT_ULL(45)
|
|
#define XHCI_VLI_TRB_CACHE_BUG BIT_ULL(46)
|
|
+#define XHCI_VLI_SS_BULK_OUT_BUG BIT_ULL(47)
|
|
|
|
unsigned int num_active_eps;
|
|
unsigned int limit_active_eps;
|