mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-24 15:56:49 +00:00
8b52a8906b
As usual these patches were extracted and rebased from the raspberry pi repo: https://github.com/raspberrypi/linux/tree/rpi-4.4.y - led1 can't be controlled on rpi-3 for linux 4.4, remove it. - Fix modules.mk typos. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
67 lines
2.2 KiB
Diff
67 lines
2.2 KiB
Diff
From 2abc666d62828bbc2889f31ebfb3754a55a51fb9 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Wed, 11 Jan 2017 13:01:21 +0000
|
|
Subject: [PATCH] BCM270X_DT: Add pi3-disable-wifi overlay
|
|
|
|
pi3-disable-wifi is a minimal overlay to disable the onboard WiFi.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 6 ++++++
|
|
arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts | 13 +++++++++++++
|
|
3 files changed, 20 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts
|
|
|
|
diff --git a/arch/arm/boot/dts/overlays/Makefile b/arch/arm/boot/dts/overlays/Makefile
|
|
index bc7f4a9..05eda03 100644
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -61,6 +61,7 @@ dtbo-$(RPI_DT_OVERLAYS) += mmc.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += mz61581.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += pi3-act-led.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += pi3-disable-bt.dtbo
|
|
+dtbo-$(RPI_DT_OVERLAYS) += pi3-disable-wifi.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += pi3-miniuart-bt.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += piscreen.dtbo
|
|
dtbo-$(RPI_DT_OVERLAYS) += piscreen2r.dtbo
|
|
diff --git a/arch/arm/boot/dts/overlays/README b/arch/arm/boot/dts/overlays/README
|
|
index 44ad21f..adb86bc 100644
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -793,6 +793,12 @@ Load: dtoverlay=pi3-disable-bt
|
|
Params: <None>
|
|
|
|
|
|
+Name: pi3-disable-wifi
|
|
+Info: Disable Pi3 onboard WiFi
|
|
+Load: dtoverlay=pi3-disable-wifi
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: pi3-miniuart-bt
|
|
Info: Switch Pi3 Bluetooth function to use the mini-UART (ttyS0) and restore
|
|
UART0/ttyAMA0 over GPIOs 14 & 15. Note that this may reduce the maximum
|
|
diff --git a/arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts b/arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts
|
|
new file mode 100644
|
|
index 0000000..0171995
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/pi3-disable-wifi-overlay.dts
|
|
@@ -0,0 +1,13 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/{
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&mmc>;
|
|
+ __overlay__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+};
|
|
--
|
|
2.1.4
|
|
|