mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-25 00:11:13 +00:00
983605e61f
78cd384 Update README and patchlevel.h for 2.4.8 release 5d03403 pppd: Avoid use of strnlen (and strlen) in vslprintf a1e950a pppd: Fix IPv6 default route code for Solaris ca5e61b plugins/rp-pppoe: Make tag parsing loop condition more accurate c10c3c7 pppd: Make sure word read from options file is null-terminated b311e98 pppd: Limit memory accessed by string formats with max length specified 3ea9de9 pppd: Eliminate some more compiler warnings 57edb1a pppd: Include time.h header before using time_t 09f695f pppd: Don't free static string 03104ba pppd.h: Add missing headers 388597e pppd: Add defaultroute6 and related options 66ce4ba pppd: Avoid declarations within statements in main.c 5637180 pppd: Fix `ifname` option in case of multilink (#105) d00f8a0 pppd: Fix variable reference syntax in Makefile.linux b6b4d28 pppd: Check tdb pointer before closing Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
50 lines
1.6 KiB
Diff
50 lines
1.6 KiB
Diff
pppd: tune Linux config defaults for OpenWrt
|
|
|
|
This patch adjusts a number defaults to properly match the OpenWrt environment.
|
|
It is not intended for upstream.
|
|
|
|
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
|
|
|
|
--- a/pppd/Makefile.linux
|
|
+++ b/pppd/Makefile.linux
|
|
@@ -48,7 +48,7 @@ MPPE=y
|
|
# Uncomment the next line to include support for PPP packet filtering.
|
|
# This requires that the libpcap library and headers be installed
|
|
# and that the kernel driver support PPP packet filtering.
|
|
-FILTER=y
|
|
+#FILTER=y
|
|
|
|
# Uncomment the next line to enable multilink PPP (enabled by default)
|
|
# Linux distributions: Please leave multilink ENABLED in your builds
|
|
@@ -58,7 +58,7 @@ HAVE_MULTILINK=y
|
|
# Uncomment the next line to enable the TDB database (enabled by default.)
|
|
# If you enable multilink, then TDB is automatically enabled also.
|
|
# Linux distributions: Please leave TDB ENABLED in your builds.
|
|
-USE_TDB=y
|
|
+#USE_TDB=y
|
|
|
|
# Uncomment the next line to enable Type=notify services in systemd
|
|
# If enabled, and the user sets the up_sdnotify option, then
|
|
@@ -85,7 +85,7 @@ MAXOCTETS=y
|
|
|
|
INCLUDE_DIRS= -I../include
|
|
|
|
-COMPILE_FLAGS= -DHAVE_PATHS_H -DIPX_CHANGE -DHAVE_MMAP
|
|
+COMPILE_FLAGS= -DHAVE_PATHS_H -DHAVE_MMAP
|
|
|
|
CFLAGS= $(COPTS) $(COMPILE_FLAGS) $(INCLUDE_DIRS) '-DDESTDIR="@DESTDIR@"'
|
|
|
|
@@ -125,10 +125,10 @@ CFLAGS += -DHAS_SHADOW
|
|
#LIBS += -lshadow $(LIBS)
|
|
endif
|
|
|
|
-ifneq ($(wildcard $(shell $(CC) --print-sysroot)/usr/include/crypt.h),)
|
|
+#ifneq ($(wildcard $(shell $(CC) --print-sysroot)/usr/include/crypt.h),)
|
|
CFLAGS += -DHAVE_CRYPT_H=1
|
|
LIBS += -lcrypt
|
|
-endif
|
|
+#endif
|
|
|
|
ifdef USE_LIBUTIL
|
|
CFLAGS += -DHAVE_LOGWTMP=1
|