mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
89f71ebb35
This fixes the build problems for the REALTEK target by adding a proper configuration option for the phy module. Signed-off-by: Birger Koblitz <mail@birger-koblitz.de>
26 lines
731 B
Diff
26 lines
731 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -454,6 +454,12 @@
|
|
---help---
|
|
Supports the Realtek 821x PHY.
|
|
|
|
+config REALTEK_SOC_PHY
|
|
+ tristate "Realtek SoC PHYs"
|
|
+ depends on RTL838X
|
|
+ ---help---
|
|
+ Supports the PHYs found in combination with Realtek Switch SoCs
|
|
+
|
|
config RENESAS_PHY
|
|
tristate "Driver for Renesas PHYs"
|
|
---help---
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -87,6 +87,7 @@
|
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_REALTEK_SOC_PHY) += rtl83xx-phy.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|