mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
edd53df168
When doing parallel build on a fast machine with bottleneck in i/o, m_xt.so may start linking faster than dynsyms.list gets populated, resulting in error: ld:dynsyms.list:0: syntax error in dynamic list Fix this by adding dynsyms.list as make dependency to m_xt.so Described also here: https://bugs.openwrt.org/index.php?do=details&task_id=3353 Change from v1: - add dynsysms.list dependancy only when shared libs are enabled Signed-off-by: Roman Yeryomin <roman@advem.lv> Fixes: FS#3353
46 lines
1.5 KiB
Diff
46 lines
1.5 KiB
Diff
--- a/tc/Makefile
|
|
+++ b/tc/Makefile
|
|
@@ -114,7 +114,7 @@ LDLIBS += -L. -lm
|
|
|
|
ifeq ($(SHARED_LIBS),y)
|
|
LDLIBS += -ldl
|
|
-LDFLAGS += -Wl,-export-dynamic
|
|
+LDFLAGS += -Wl,--dynamic-list=dynsyms.list
|
|
endif
|
|
|
|
TCLIB := tc_core.o
|
|
@@ -144,7 +144,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
|
|
all: tc $(TCSO)
|
|
|
|
tc: $(TCOBJ) $(LIBNETLINK) libtc.a
|
|
- $(QUIET_LINK)$(CC) $^ $(LDFLAGS) $(LDLIBS) -o $@
|
|
+ $(QUIET_LINK)$(CC) $(filter-out dynsyms.list, $^) $(LDFLAGS) $(LDLIBS) -o $@
|
|
|
|
libtc.a: $(TCLIB)
|
|
$(QUIET_AR)$(AR) rcs $@ $^
|
|
@@ -166,6 +166,7 @@ install: all
|
|
clean:
|
|
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.tab.h; \
|
|
rm -f emp_ematch.tab.*
|
|
+ rm -f dynsyms.list
|
|
|
|
q_atm.so: q_atm.c
|
|
$(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
|
|
@@ -205,4 +206,16 @@ static-syms.h: $(wildcard *.c)
|
|
sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
|
|
done > $@
|
|
|
|
+else
|
|
+
|
|
+tc: dynsyms.list
|
|
+m_xt.so: dynsyms.list
|
|
+dynsyms.list: $(wildcard *.c)
|
|
+ files="$(filter-out $(patsubst %.so,%.c,$(TCSO)), $^)" ; \
|
|
+ echo "{" > $@ ; \
|
|
+ for s in `grep -B 3 '\<dlsym' $$files | sed -n '/snprintf/{s:.*"\([^"]*\)".*:\1:;s:%s::;p}'` ; do \
|
|
+ sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:\1;:;p}' $$files ; \
|
|
+ done >> $@ ; \
|
|
+ echo "show_stats; print_nl; print_tm; parse_rtattr; parse_rtattr_flags; get_u32; matches; addattr_l; addattr_nest; addattr_nest_end; };" >> $@
|
|
+
|
|
endif
|