mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
8857387913
This patches does not have a valid patch headers and does not apply on an external git tree with 'git am'. To fix this add the missing headers. Signed-off-by: Florian Eckert <fe@dev.tdt.de>
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From ac84397efb3b3868c71c10ad7521161773228a17 Mon Sep 17 00:00:00 2001
|
|
From: OpenWrt community <openwrt-devel@lists.openwrt.org>
|
|
Date: Wed, 13 Jul 2022 13:41:44 +0200
|
|
Subject: [PATCH] mtd/nand: add MediaTek NAND bad block managment table
|
|
|
|
---
|
|
drivers/mtd/nand/Kconfig | 4 ++++
|
|
drivers/mtd/nand/Makefile | 1 +
|
|
2 files changed, 5 insertions(+)
|
|
|
|
diff --git a/drivers/mtd/nand/Kconfig b/drivers/mtd/nand/Kconfig
|
|
index b40455234cbd..72ef18c59cee 100644
|
|
--- a/drivers/mtd/nand/Kconfig
|
|
+++ b/drivers/mtd/nand/Kconfig
|
|
@@ -46,6 +46,10 @@ config MTD_NAND_ECC_SW_BCH
|
|
ECC codes. They are used with NAND devices requiring more than 1 bit
|
|
of error correction.
|
|
|
|
+config MTD_NAND_MTK_BMT
|
|
+ bool "Support MediaTek NAND Bad-block Management Table"
|
|
+ default n
|
|
+
|
|
endmenu
|
|
|
|
endmenu
|
|
diff --git a/drivers/mtd/nand/Makefile b/drivers/mtd/nand/Makefile
|
|
index 1c0b46960eb1..b9d97626bb47 100644
|
|
--- a/drivers/mtd/nand/Makefile
|
|
+++ b/drivers/mtd/nand/Makefile
|
|
@@ -2,6 +2,7 @@
|
|
|
|
nandcore-objs := core.o bbt.o
|
|
obj-$(CONFIG_MTD_NAND_CORE) += nandcore.o
|
|
+obj-$(CONFIG_MTD_NAND_MTK_BMT) += mtk_bmt.o mtk_bmt_v2.o mtk_bmt_bbt.o mtk_bmt_nmbm.o
|
|
|
|
obj-y += onenand/
|
|
obj-y += raw/
|
|
--
|
|
|