mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-29 10:08:59 +00:00
102009f3ea
with 6.1, the kernel no longer fitted into the 16 MiB and kicking down the can and increasing KERNEL_SIZE to 20 MiB didn't help as the device failed to boot. Using 'kernel-bin | gzip | uimage gzip' didn't work since the uboot does not have enough heap to decompress these big kernels. And finally playing around with uboot was more a hassle than converting this device to take the simpleImage-boot-route in the future. Note: The device now takes even longer on the first boot-up after the flash due to JFFS2 initializing all the remaining flash. Be prepared to wait up to 10 minutes before the green status LED stops blinking and will shine a solid green! (On the plus site: the device now has ~10 MiB of additional space for rootfs+rootfs_data). Note2: This patch includes a kernel patch refresh. Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
--- a/arch/powerpc/platforms/85xx/Kconfig
|
|
+++ b/arch/powerpc/platforms/85xx/Kconfig
|
|
@@ -73,6 +73,17 @@ config WS_AP3710I
|
|
This board is a Concurrent Dual-Band wireless access point with a
|
|
Freescale P1020 SoC.
|
|
|
|
+config WS_AP3715I
|
|
+ bool "Enterasys WS-AP3715i"
|
|
+ select DEFAULT_UIMAGE
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select GPIO_MPC8XXX
|
|
+ help
|
|
+ This option enables support for the Enterasys WS-AP3715i board.
|
|
+
|
|
+ This board is a Concurrent Dual-Band wireless access point with a
|
|
+ Freescale P1010 SoC.
|
|
+
|
|
config WS_AP3825I
|
|
bool "Extreme Networks WS-AP3825i"
|
|
select DEFAULT_UIMAGE
|
|
--- a/arch/powerpc/platforms/85xx/Makefile
|
|
+++ b/arch/powerpc/platforms/85xx/Makefile
|
|
@@ -27,6 +27,7 @@ obj-$(CONFIG_P1023_RDB) += p1023_rdb.o
|
|
obj-$(CONFIG_PANDA) += panda.o
|
|
obj-$(CONFIG_TWR_P102x) += twr_p102x.o
|
|
obj-$(CONFIG_WS_AP3710I) += ws-ap3710i.o
|
|
+obj-$(CONFIG_WS_AP3715I) += ws-ap3715i.o
|
|
obj-$(CONFIG_WS_AP3825I) += ws-ap3825i.o
|
|
obj-$(CONFIG_FIREBOX_T10) += firebox_t10.o
|
|
obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -364,6 +364,7 @@ image-$(CONFIG_TQM8560) += cuImage.tqm
|
|
image-$(CONFIG_KSI8560) += cuImage.ksi8560
|
|
image-$(CONFIG_HIVEAP_330) += simpleImage.hiveap-330
|
|
image-$(CONFIG_TL_WDR4900_V1) += simpleImage.tl-wdr4900-v1
|
|
+image-$(CONFIG_WS_AP3715I) += simpleImage.ws-ap3715i
|
|
image-$(CONFIG_WS_AP3825I) += simpleImage.ws-ap3825i
|
|
# Board ports in arch/powerpc/platform/86xx/Kconfig
|
|
image-$(CONFIG_MVME7100) += dtbImage.mvme7100
|
|
--- a/arch/powerpc/boot/wrapper
|
|
+++ b/arch/powerpc/boot/wrapper
|
|
@@ -342,6 +342,7 @@ adder875-redboot)
|
|
binary=y
|
|
;;
|
|
simpleboot-hiveap-330|\
|
|
+simpleboot-ws-ap3715i|\
|
|
simpleboot-ws-ap3825i|\
|
|
simpleboot-tl-wdr4900-v1)
|
|
platformo="$object/fixed-head.o $object/simpleboot.o"
|