mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
8299d1f057
Rebased RPi foundation patches on linux 5.10.59, removed applied and reverted patches, wireless patches and defconfig patches. bcm2708: boot tested on RPi B+ v1.2 bcm2709: boot tested on RPi 4B v1.1 4G bcm2711: boot tested on RPi 4B v1.1 4G Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
76 lines
2.8 KiB
Diff
76 lines
2.8 KiB
Diff
From 022c80564d30bba83b82a0ccdff74648e47862dd Mon Sep 17 00:00:00 2001
|
|
From: Serge Schneider <serge@raspberrypi.com>
|
|
Date: Mon, 2 Dec 2019 14:48:05 +0000
|
|
Subject: [PATCH] overlays: Add rpi-poe-plus overlay
|
|
|
|
Signed-off-by: Serge Schneider <serge@raspberrypi.com>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 21 +++++++++++++++++++
|
|
.../dts/overlays/rpi-poe-plus-overlay.dts | 19 +++++++++++++++++
|
|
3 files changed, 41 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/rpi-poe-plus-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -156,6 +156,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
rpi-display.dtbo \
|
|
rpi-ft5406.dtbo \
|
|
rpi-poe.dtbo \
|
|
+ rpi-poe-plus.dtbo \
|
|
rpi-proto.dtbo \
|
|
rpi-sense.dtbo \
|
|
rpi-tv.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -2505,6 +2505,27 @@ Params: poe_fan_temp0 Temperat
|
|
the fan slows down (default 5000)
|
|
|
|
|
|
+Name: rpi-poe-plus
|
|
+Info: Raspberry Pi PoE+ HAT fan
|
|
+Load: dtoverlay=rpi-poe-plus,<param>[=<val>]
|
|
+Params: poe_fan_temp0 Temperature (in millicelcius) at which the fan
|
|
+ turns on (default 40000)
|
|
+ poe_fan_temp0_hyst Temperature delta (in millicelcius) at which
|
|
+ the fan turns off (default 2000)
|
|
+ poe_fan_temp1 Temperature (in millicelcius) at which the fan
|
|
+ speeds up (default 45000)
|
|
+ poe_fan_temp1_hyst Temperature delta (in millicelcius) at which
|
|
+ the fan slows down (default 2000)
|
|
+ poe_fan_temp2 Temperature (in millicelcius) at which the fan
|
|
+ speeds up (default 50000)
|
|
+ poe_fan_temp2_hyst Temperature delta (in millicelcius) at which
|
|
+ the fan slows down (default 2000)
|
|
+ poe_fan_temp3 Temperature (in millicelcius) at which the fan
|
|
+ speeds up (default 55000)
|
|
+ poe_fan_temp3_hyst Temperature delta (in millicelcius) at which
|
|
+ the fan slows down (default 5000)
|
|
+
|
|
+
|
|
Name: rpi-proto
|
|
Info: Configures the RPi Proto audio card
|
|
Load: dtoverlay=rpi-proto
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/rpi-poe-plus-overlay.dts
|
|
@@ -0,0 +1,19 @@
|
|
+// SPDX-License-Identifier: (GPL-2.0 OR MIT)
|
|
+// Overlay for the Raspberry Pi PoE+ HAT.
|
|
+
|
|
+#include "rpi-poe-overlay.dts"
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835";
|
|
+
|
|
+ fragment@3 {
|
|
+ target-path = "/";
|
|
+ __overlay__ {
|
|
+ rpi_poe_power_supply: rpi-poe-power-supply@0 {
|
|
+ compatible = "raspberrypi,rpi-poe-power-supply";
|
|
+ firmware = <&firmware>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|