mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
537b423d9f
Remove patches adding support for MT7621 which have been merged upsteam. Patches for MT7981 and MT7986 have been merged too, but not in time to be included in the 2022.10 release, so we have to keep carrying them until the 2023.01 release. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
31 lines
951 B
Diff
31 lines
951 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -2032,26 +2032,7 @@ endif
|
|
# Check dtc and pylibfdt, if DTC is provided, else build them
|
|
PHONY += scripts_dtc
|
|
scripts_dtc: scripts_basic
|
|
- $(Q)if test "$(DTC)" = "$(DTC_INTREE)"; then \
|
|
- $(MAKE) $(build)=scripts/dtc; \
|
|
- else \
|
|
- if ! $(DTC) -v >/dev/null; then \
|
|
- echo '*** Failed to check dtc version: $(DTC)'; \
|
|
- false; \
|
|
- else \
|
|
- if test "$(call dtc-version)" -lt $(DTC_MIN_VERSION); then \
|
|
- echo '*** Your dtc is too old, please upgrade to dtc $(DTC_MIN_VERSION) or newer'; \
|
|
- false; \
|
|
- else \
|
|
- if [ -n "$(CONFIG_PYLIBFDT)" ]; then \
|
|
- if ! echo "import libfdt" | $(PYTHON3) 2>/dev/null; then \
|
|
- echo '*** pylibfdt does not seem to be available with $(PYTHON3)'; \
|
|
- false; \
|
|
- fi; \
|
|
- fi; \
|
|
- fi; \
|
|
- fi; \
|
|
- fi
|
|
+ $(MAKE) $(build)=scripts/dtc
|
|
|
|
# ---------------------------------------------------------------------------
|
|
quiet_cmd_cpp_lds = LDS $@
|