mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
f5919b65d4
Patch generation process: - rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable - git format-patch v4.14.89 Patches skipped during rebase: - lan78xx: Read MAC address from DT if present - lan78xx: Enable LEDs and auto-negotiation - Revert "softirq: Let ksoftirqd do its job" - sc16is7xx: Fix for multi-channel stall - lan78xx: Ignore DT MAC address if already valid - lan78xx: Simple patch to prevent some crashes - tcp_write_queue_purge clears all the SKBs in the write queue - Revert "lan78xx: Simple patch to prevent some crashes" - lan78xx: Connect phy early - Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro - Revert "Revert "softirq: Let ksoftirqd do its job"" - ASoC: cs4265: SOC_SINGLE register value error fix - Revert "ASoC: cs4265: SOC_SINGLE register value error fix" - Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends" - Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"" Patches dropped after rebase: - net: Add non-mainline source for rtl8192cu wlan - net: Fix rtl8192cu build errors on other platforms - brcm: adds support for BCM43341 wifi - brcmfmac: Mute expected startup 'errors' - ARM64: Fix build break for RTL8187/RTL8192CU wifi - ARM64: Enable RTL8187/RTL8192CU wifi in build config - This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator - brcmfmac: add CLM download support - brcmfmac: request_firmware_direct is quieter - Sets the BCDC priority to constant 0 - brcmfmac: Disable ARP offloading when promiscuous - brcmfmac: Avoid possible out-of-bounds read - brcmfmac: Delete redundant length check - net: rtl8192cu: Normalize indentation - net: rtl8192cu: Fix implicit fallthrough warnings - Revert "Sets the BCDC priority to constant 0" - media: cxd2880: Bump to match 4.18.y version - media: cxd2880-spi: Bump to match 4.18.y version - Revert "mm: alloc_contig: re-allow CMA to compact FS pages" - Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages"" - cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with MEDIA_SUBDRV_AUTOSELECT - 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch - 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch Make I2C built-in instead of modular as in upstream defconfig; also the easiest way to get MFD_ARIZONA enabled, which is required by kmod-sound-soc-rpi-cirrus. Add missing compatible strings from 4.9/960-add-rasbperrypi-compatible.patch, using upstream names for compute modules. Add extra patch to enable the LEDs on lan78xx. Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y) Runtime-tested: bcm2708, bcm2710 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
82 lines
2.3 KiB
Diff
82 lines
2.3 KiB
Diff
From f0f4af3ddb0fc5ea529c0147ebf8be47b1a80335 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Fri, 12 Jan 2018 09:15:01 +0000
|
|
Subject: [PATCH 159/454] overlays: Add uart0 overlay to change pin usage
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 13 +++++++-
|
|
arch/arm/boot/dts/overlays/uart0-overlay.dts | 32 ++++++++++++++++++++
|
|
3 files changed, 45 insertions(+), 1 deletion(-)
|
|
create mode 100755 arch/arm/boot/dts/overlays/uart0-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -117,6 +117,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
spi2-2cs.dtbo \
|
|
spi2-3cs.dtbo \
|
|
tinylcd35.dtbo \
|
|
+ uart0.dtbo \
|
|
uart1.dtbo \
|
|
vc4-fkms-v3d.dtbo \
|
|
vc4-kms-v3d.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -1671,8 +1671,19 @@ Params: speed Display
|
|
dtoverlay=tinylcd35,touch,touchgpio=3
|
|
|
|
|
|
+Name: uart0
|
|
+Info: Change the pin usage of uart0
|
|
+Load: dtoverlay=uart0,<param>=<val>
|
|
+Params: txd0_pin GPIO pin for TXD0 (14, 32 or 36 - default 14)
|
|
+
|
|
+ rxd0_pin GPIO pin for RXD0 (15, 33 or 37 - default 15)
|
|
+
|
|
+ pin_func Alternative pin function - 4(Alt0) for 14&15,
|
|
+ 7(Alt3) for 32&33, 6(Alt2) for 36&37
|
|
+
|
|
+
|
|
Name: uart1
|
|
-Info: Enable uart1 in place of uart0
|
|
+Info: Change the pin usage of uart1
|
|
Load: dtoverlay=uart1,<param>=<val>
|
|
Params: txd1_pin GPIO pin for TXD1 (14, 32 or 40 - default 14)
|
|
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/uart0-overlay.dts
|
|
@@ -0,0 +1,32 @@
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/{
|
|
+ compatible = "brcm,bcm2708";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&uart0>;
|
|
+ __overlay__ {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart0_pins>;
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&gpio>;
|
|
+ __overlay__ {
|
|
+ uart0_pins: uart0_pins {
|
|
+ brcm,pins = <14 15>;
|
|
+ brcm,function = <4>; /* alt0 */
|
|
+ brcm,pull = <0 2>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+
|
|
+ __overrides__ {
|
|
+ txd0_pin = <&uart0_pins>,"brcm,pins:0";
|
|
+ rxd0_pin = <&uart0_pins>,"brcm,pins:4";
|
|
+ pin_func = <&uart0_pins>,"brcm,function:0";
|
|
+ };
|
|
+};
|