openwrt/target/linux/brcm2708/patches-4.14/950-0146-Add-overlay-for-mcp3202-12-bit-ADC.patch
Stijn Tintel f5919b65d4 brcm2708: add kernel 4.14 support
Patch generation process:
- rebase rpi/rpi-4.14.y on v4.14.89 from linux-stable
- git format-patch v4.14.89

Patches skipped during rebase:
- lan78xx: Read MAC address from DT if present
- lan78xx: Enable LEDs and auto-negotiation
- Revert "softirq: Let ksoftirqd do its job"
- sc16is7xx: Fix for multi-channel stall
- lan78xx: Ignore DT MAC address if already valid
- lan78xx: Simple patch to prevent some crashes
- tcp_write_queue_purge clears all the SKBs in the write queue
- Revert "lan78xx: Simple patch to prevent some crashes"
- lan78xx: Connect phy early
- Arm: mm: ftrace: Only set text back to ro after kernel has been marked ro
- Revert "Revert "softirq: Let ksoftirqd do its job""
- ASoC: cs4265: SOC_SINGLE register value error fix
- Revert "ASoC: cs4265: SOC_SINGLE register value error fix"
- Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends"
- Revert "Revert "net: pskb_trim_rcsum() and CHECKSUM_COMPLETE are friends""

Patches dropped after rebase:
- net: Add non-mainline source for rtl8192cu wlan
- net: Fix rtl8192cu build errors on other platforms
- brcm: adds support for BCM43341 wifi
- brcmfmac: Mute expected startup 'errors'
- ARM64: Fix build break for RTL8187/RTL8192CU wifi
- ARM64: Enable RTL8187/RTL8192CU wifi in build config
- This is the driver for Sony CXD2880 DVB-T2/T tuner + demodulator
- brcmfmac: add CLM download support
- brcmfmac: request_firmware_direct is quieter
- Sets the BCDC priority to constant 0
- brcmfmac: Disable ARP offloading when promiscuous
- brcmfmac: Avoid possible out-of-bounds read
- brcmfmac: Delete redundant length check
- net: rtl8192cu: Normalize indentation
- net: rtl8192cu: Fix implicit fallthrough warnings
- Revert "Sets the BCDC priority to constant 0"
- media: cxd2880: Bump to match 4.18.y version
- media: cxd2880-spi: Bump to match 4.18.y version
- Revert "mm: alloc_contig: re-allow CMA to compact FS pages"
- Revert "Revert "mm: alloc_contig: re-allow CMA to compact FS pages""
- cxd2880: CXD2880_SPI_DRV should select DVB_CXD2880 with
  MEDIA_SUBDRV_AUTOSELECT
- 950-0421-HID-hid-bigbenff-driver-for-BigBen-Interactive-PS3OF.patch
- 950-0453-Add-hid-bigbenff-to-list-of-have_special_driver-for-.patch

Make I2C built-in instead of modular as in upstream defconfig; also the
easiest way to get MFD_ARIZONA enabled, which is required by
kmod-sound-soc-rpi-cirrus.
Add missing compatible strings from
4.9/960-add-rasbperrypi-compatible.patch, using upstream names for
compute modules.
Add extra patch to enable the LEDs on lan78xx.

Compile-tested: bcm2708, bcm2709, bcm2710 (with CONFIG_ALL_KMODS=y)
Runtime-tested: bcm2708, bcm2710

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
2018-12-18 23:19:21 +02:00

249 lines
5.3 KiB
Diff

From ab6b50d10b73ed3150dd80633131b7d56c1c63df Mon Sep 17 00:00:00 2001
From: penfold42 <penfold42@users.noreply.github.com>
Date: Tue, 2 Jan 2018 00:15:19 +1100
Subject: [PATCH 146/454] Add overlay for mcp3202 12 bit ADC
---
arch/arm/boot/dts/overlays/Makefile | 1 +
arch/arm/boot/dts/overlays/README | 9 +
.../arm/boot/dts/overlays/mcp3202-overlay.dts | 205 ++++++++++++++++++
3 files changed, 215 insertions(+)
create mode 100755 arch/arm/boot/dts/overlays/mcp3202-overlay.dts
--- a/arch/arm/boot/dts/overlays/Makefile
+++ b/arch/arm/boot/dts/overlays/Makefile
@@ -61,6 +61,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
mcp2515-can0.dtbo \
mcp2515-can1.dtbo \
mcp3008.dtbo \
+ mcp3202.dtbo \
media-center.dtbo \
midi-uart0.dtbo \
midi-uart1.dtbo \
--- a/arch/arm/boot/dts/overlays/README
+++ b/arch/arm/boot/dts/overlays/README
@@ -994,6 +994,15 @@ Params: spi<n>-<m>-present boolean,
spi<n>-<m>-speed integer, set the spi bus speed for this device
+Name: mcp3202
+Info: Configures MCP3202 A/D converters
+ For devices on spi1 or spi2, the interfaces should be enabled
+ with one of the spi1-1/2/3cs and/or spi2-1/2/3cs overlays.
+Load: dtoverlay=mcp3202,<param>[=<val>]
+Params: spi<n>-<m>-present boolean, configure device at spi<n>, cs<m>
+ spi<n>-<m>-speed integer, set the spi bus speed for this device
+
+
Name: media-center
Info: Media Center HAT - 2.83" Touch Display + extras by Pi Supply
Load: dtoverlay=media-center,<param>=<val>
--- /dev/null
+++ b/arch/arm/boot/dts/overlays/mcp3202-overlay.dts
@@ -0,0 +1,205 @@
+/*
+ * Device tree overlay for Microchip mcp3202 12-Bit A/D Converters
+ */
+
+/dts-v1/;
+/plugin/;
+
+/ {
+ compatible = "brcm,bcm2835", "brcm,bcm2708", "brcm,bcm2709";
+
+ fragment@0 {
+ target = <&spidev0>;
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@1 {
+ target = <&spidev1>;
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@2 {
+ target-path = "spi1/spidev@0";
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@3 {
+ target-path = "spi1/spidev@1";
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@4 {
+ target-path = "spi1/spidev@2";
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@5 {
+ target-path = "spi2/spidev@0";
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@6 {
+ target-path = "spi2/spidev@1";
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@7 {
+ target-path = "spi2/spidev@2";
+ __dormant__ {
+ status = "disabled";
+ };
+ };
+
+ fragment@8 {
+ target = <&spi0>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_00: mcp3202@0 {
+ compatible = "mcp3202";
+ reg = <0>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@9 {
+ target = <&spi0>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_01: mcp3202@1 {
+ compatible = "mcp3202";
+ reg = <1>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@10 {
+ target = <&spi1>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_10: mcp3202@0 {
+ compatible = "mcp3202";
+ reg = <0>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@11 {
+ target = <&spi1>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_11: mcp3202@1 {
+ compatible = "mcp3202";
+ reg = <1>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@12 {
+ target = <&spi1>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_12: mcp3202@2 {
+ compatible = "mcp3202";
+ reg = <2>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@13 {
+ target = <&spi2>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_20: mcp3202@0 {
+ compatible = "mcp3202";
+ reg = <0>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@14 {
+ target = <&spi2>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_21: mcp3202@1 {
+ compatible = "mcp3202";
+ reg = <1>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ fragment@15 {
+ target = <&spi2>;
+ __dormant__ {
+ status = "okay";
+ #address-cells = <1>;
+ #size-cells = <0>;
+
+ mcp3202_22: mcp3202@2 {
+ compatible = "mcp3202";
+ reg = <2>;
+ spi-max-frequency = <1600000>;
+ };
+ };
+ };
+
+ __overrides__ {
+ spi0-0-present = <0>, "+0+8";
+ spi0-1-present = <0>, "+1+9";
+ spi1-0-present = <0>, "+2+10";
+ spi1-1-present = <0>, "+3+11";
+ spi1-2-present = <0>, "+4+12";
+ spi2-0-present = <0>, "+5+13";
+ spi2-1-present = <0>, "+6+14";
+ spi2-2-present = <0>, "+7+15";
+ spi0-0-speed = <&mcp3202_00>, "spi-max-frequency:0";
+ spi0-1-speed = <&mcp3202_01>, "spi-max-frequency:0";
+ spi1-0-speed = <&mcp3202_10>, "spi-max-frequency:0";
+ spi1-1-speed = <&mcp3202_11>, "spi-max-frequency:0";
+ spi1-2-speed = <&mcp3202_12>, "spi-max-frequency:0";
+ spi2-0-speed = <&mcp3202_20>, "spi-max-frequency:0";
+ spi2-1-speed = <&mcp3202_21>, "spi-max-frequency:0";
+ spi2-2-speed = <&mcp3202_22>, "spi-max-frequency:0";
+ };
+};