mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
251a382c28
Deleted (upstreamed): generic/backport-5.15/400-mtdblock-warn-if-opened-on-NAND.patch [01] generic/backport-5.15/420-v5.19-01-mtd-spinand-gigadevice-fix-Quad-IO-for-GD5F1GQ5UExxG.patch [02] bcm27xx/patches-5.15/950-0029-Revert-mailbox-avoid-timer-start-from-callback.patch [03] bcm27xx/patches-5.15/950-0417-bcm2711_thermal-Don-t-clamp-temperature-at-zero.patch [04] bcm27xx/patches-5.15/950-0740-drm-vc4-hvs-Fix-frame-count-register-readout.patch [05] bcm27xx/patches-5.15/950-0755-drm-vc4-hvs-Reset-muxes-at-probe-time.patch [06] bcm27xx/patches-5.15/950-0759-drm-vc4-txp-Don-t-set-TXP_VSTART_AT_EOF.patch [07] bcm27xx/patches-5.15/950-0760-drm-vc4-txp-Force-alpha-to-be-0xff-if-it-s-disabled.patch [08] bcm53xx/patches-5.15/031-v5.17-0005-ARM-dts-BCM5301X-update-CRU-block-description.patch [09] mediatek/patches-5.15/102-mt7629-enable-arch-timer.patch [10] Manually rebased: bcm27xx/patches-5.15/950-0741-drm-vc4-hvs-Use-pointer-to-HVS-in-HVS_READ-and-HVS_W.patch [01] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=f41c9418c5898c01634675150696da290fb86796 [02] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=d5b66645305c6f3a1b2cf75cee4157b07f293309 [03] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=119f99209d8531359bcb935f252ec435f9d21b13 [04] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=c4e1280abead1552e1764684079a43e222ccd163 [05] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=08465a1889cb48ec64431e9db745b5be15399251 [06] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=0e26a6da02e63b75b629573d13966c36aa6264f0 [07] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=01c9020b2e7c85e394879f34851805179ac3d1d8 [08] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=d47f85cc0171a5d3c5bd8cbb8a98983ca3357cbd [09] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=5151f24ac937ff7eb1f078257c66e3c0f0296010 [10] https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.46&id=ffea838686b82fbb2801cdfad6ba5309d15c032d Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
80 lines
2.7 KiB
Diff
80 lines
2.7 KiB
Diff
From patchwork Thu Feb 6 17:19:41 2020
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
X-Patchwork-Submitter: Daniel Golle <daniel@makrotopia.org>
|
|
X-Patchwork-Id: 1234465
|
|
Date: Thu, 6 Feb 2020 19:19:41 +0200
|
|
From: Daniel Golle <daniel@makrotopia.org>
|
|
To: linux-mtd@lists.infradead.org
|
|
Subject: [PATCH v2] mtd: spi-nor: Add support for xt25f128b chip
|
|
Message-ID: <20200206171941.GA2398@makrotopia.org>
|
|
MIME-Version: 1.0
|
|
Content-Disposition: inline
|
|
List-Subscribe: <http://lists.infradead.org/mailman/listinfo/linux-mtd>,
|
|
<mailto:linux-mtd-request@lists.infradead.org?subject=subscribe>
|
|
Cc: Eitan Cohen <eitan@neot-semadar.com>, Piotr Dymacz <pepe2k@gmail.com>,
|
|
Tudor Ambarus <tudor.ambarus@microchip.com>
|
|
Sender: "linux-mtd" <linux-mtd-bounces@lists.infradead.org>
|
|
Errors-To: linux-mtd-bounces+incoming=patchwork.ozlabs.org@lists.infradead.org
|
|
|
|
Add XT25F128B made by XTX Technology (Shenzhen) Limited.
|
|
This chip supports dual and quad read and uniform 4K-byte erase.
|
|
Verified on Teltonika RUT955 which comes with XT25F128B in recent
|
|
versions of the device.
|
|
|
|
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
drivers/mtd/spi-nor/spi-nor.c | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
--- a/drivers/mtd/spi-nor/Makefile
|
|
+++ b/drivers/mtd/spi-nor/Makefile
|
|
@@ -17,6 +17,7 @@ spi-nor-objs += sst.o
|
|
spi-nor-objs += winbond.o
|
|
spi-nor-objs += xilinx.o
|
|
spi-nor-objs += xmc.o
|
|
+spi-nor-objs += xtx.o
|
|
obj-$(CONFIG_MTD_SPI_NOR) += spi-nor.o
|
|
|
|
obj-$(CONFIG_MTD_SPI_NOR) += controllers/
|
|
--- /dev/null
|
|
+++ b/drivers/mtd/spi-nor/xtx.c
|
|
@@ -0,0 +1,15 @@
|
|
+// SPDX-License-Identifier: GPL-2.0
|
|
+#include <linux/mtd/spi-nor.h>
|
|
+
|
|
+#include "core.h"
|
|
+
|
|
+static const struct flash_info xtx_parts[] = {
|
|
+ /* XTX Technology (Shenzhen) Limited */
|
|
+ { "xt25f128b", INFO(0x0B4018, 0, 64 * 1024, 256, SECT_4K | SPI_NOR_DUAL_READ | SPI_NOR_QUAD_READ) },
|
|
+};
|
|
+
|
|
+const struct spi_nor_manufacturer spi_nor_xtx = {
|
|
+ .name = "xtx",
|
|
+ .parts = xtx_parts,
|
|
+ .nparts = ARRAY_SIZE(xtx_parts),
|
|
+};
|
|
--- a/drivers/mtd/spi-nor/core.c
|
|
+++ b/drivers/mtd/spi-nor/core.c
|
|
@@ -1857,6 +1857,7 @@ static const struct spi_nor_manufacturer
|
|
&spi_nor_winbond,
|
|
&spi_nor_xilinx,
|
|
&spi_nor_xmc,
|
|
+ &spi_nor_xtx,
|
|
};
|
|
|
|
static const struct flash_info *
|
|
--- a/drivers/mtd/spi-nor/core.h
|
|
+++ b/drivers/mtd/spi-nor/core.h
|
|
@@ -489,6 +489,7 @@ extern const struct spi_nor_manufacturer
|
|
extern const struct spi_nor_manufacturer spi_nor_winbond;
|
|
extern const struct spi_nor_manufacturer spi_nor_xilinx;
|
|
extern const struct spi_nor_manufacturer spi_nor_xmc;
|
|
+extern const struct spi_nor_manufacturer spi_nor_xtx;
|
|
|
|
extern const struct attribute_group *spi_nor_sysfs_groups[];
|
|
|