mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 08:51:13 +00:00
7d7aa2fd92
This change makes the names of Broadcom targets consistent by using the common notation based on SoC/CPU ID (which is used internally anyway), bcmXXXX instead of brcmXXXX. This is even used for target TITLE in make menuconfig already, only the short target name used brcm so far. Despite, since subtargets range from bcm2708 to bcm2711, it seems appropriate to use bcm27xx instead of bcm2708 (again, as already done for BOARDNAME). This also renames the packages brcm2708-userland and brcm2708-gpu-fw. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Acked-by: Álvaro Fernández Rojas <noltari@gmail.com>
93 lines
2.5 KiB
Diff
93 lines
2.5 KiB
Diff
From 82298c670f768f392f48526fe7c8a93682e83998 Mon Sep 17 00:00:00 2001
|
|
From: Peter Huewe <peterhuewe@gmx.de>
|
|
Date: Thu, 14 Jun 2018 22:51:24 +0200
|
|
Subject: [PATCH] Add overlay for SLB9760 Iridium /LetsTrust TPM
|
|
|
|
Device Tree overlay for the Infineon SLB9670 Trusted Platform Module add-on
|
|
boards, which can be used as a secure key storage and hwrng.
|
|
available as "Iridium SLB9670" by Infineon and "LetsTrust TPM" by
|
|
pi3g.
|
|
|
|
Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
|
|
---
|
|
arch/arm/boot/dts/overlays/Makefile | 1 +
|
|
arch/arm/boot/dts/overlays/README | 8 ++++
|
|
.../boot/dts/overlays/tpm-slb9670-overlay.dts | 44 +++++++++++++++++++
|
|
3 files changed, 53 insertions(+)
|
|
create mode 100644 arch/arm/boot/dts/overlays/tpm-slb9670-overlay.dts
|
|
|
|
--- a/arch/arm/boot/dts/overlays/Makefile
|
|
+++ b/arch/arm/boot/dts/overlays/Makefile
|
|
@@ -137,6 +137,7 @@ dtbo-$(CONFIG_ARCH_BCM2835) += \
|
|
tc358743.dtbo \
|
|
tc358743-audio.dtbo \
|
|
tinylcd35.dtbo \
|
|
+ tpm-slb9670.dtbo \
|
|
uart0.dtbo \
|
|
uart1.dtbo \
|
|
upstream.dtbo \
|
|
--- a/arch/arm/boot/dts/overlays/README
|
|
+++ b/arch/arm/boot/dts/overlays/README
|
|
@@ -2012,6 +2012,14 @@ Params: speed Display
|
|
dtoverlay=tinylcd35,touch,touchgpio=3
|
|
|
|
|
|
+Name: tpm-slb9670
|
|
+Info: Enables support for Infineon SLB9670 Trusted Platform Module add-on
|
|
+ boards, which can be used as a secure key storage and hwrng,
|
|
+ available as "Iridium SLB9670" by Infineon and "LetsTrust TPM" by pi3g.
|
|
+Load: dtoverlay=tpm-slb9670
|
|
+Params: <None>
|
|
+
|
|
+
|
|
Name: uart0
|
|
Info: Change the pin usage of uart0
|
|
Load: dtoverlay=uart0,<param>=<val>
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/overlays/tpm-slb9670-overlay.dts
|
|
@@ -0,0 +1,44 @@
|
|
+/*
|
|
+ * Device Tree overlay for the Infineon SLB9670 Trusted Platform Module add-on
|
|
+ * boards, which can be used as a secure key storage and hwrng.
|
|
+ * available as "Iridium SLB9670" by Infineon and "LetsTrust TPM" by pi3g.
|
|
+ */
|
|
+
|
|
+/dts-v1/;
|
|
+/plugin/;
|
|
+
|
|
+/ {
|
|
+ compatible = "brcm,bcm2835", "brcm,bcm2708", "brcm,bcm2709";
|
|
+
|
|
+ fragment@0 {
|
|
+ target = <&spi0>;
|
|
+ __overlay__ {
|
|
+ status = "okay";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@1 {
|
|
+ target = <&spidev1>;
|
|
+ __overlay__ {
|
|
+ status = "disabled";
|
|
+ };
|
|
+ };
|
|
+
|
|
+ fragment@2 {
|
|
+ target = <&spi0>;
|
|
+ __overlay__ {
|
|
+ /* needed to avoid dtc warning */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ slb9670: slb9670@1 {
|
|
+ compatible = "infineon,slb9670";
|
|
+ reg = <1>; /* CE1 */
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ spi-max-frequency = <32000000>;
|
|
+ status = "okay";
|
|
+ };
|
|
+
|
|
+ };
|
|
+ };
|
|
+};
|