mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-19 13:48:06 +00:00
eec18118d0
Convert the Enterasys WS-AP3710i access point to use the simpleImage wrapper. This is necessary, as the bootlaoder does not align the DTB correctly (and does not support altering the FDT loadaddress). Booting images with kernels 5.15 and later can break depending on the alignment on the DTB within the FIT image. Signed-off-by: David Bauer <mail@david-bauer.net>
43 lines
1.5 KiB
Diff
43 lines
1.5 KiB
Diff
From d43ab14605510d9d2bd257a8cd70f24ada4621b0 Mon Sep 17 00:00:00 2001
|
|
From: David Bauer <mail@david-bauer.net>
|
|
Date: Sat, 29 Feb 2020 14:27:04 +0100
|
|
Subject: [PATCH] powerpc: bootwrapper: disable uImage generation
|
|
|
|
Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
|
|
instruct the mkimage to use the xz compression, which isn't
|
|
supported. This disables the uImage generation, as OpenWrt
|
|
generates individual uImages for each board using it's own
|
|
toolchain.
|
|
|
|
Signed-off-by: David Bauer <mail@david-bauer.net>
|
|
---
|
|
arch/powerpc/boot/Makefile | 9 ---------
|
|
1 file changed, 9 deletions(-)
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -295,7 +295,6 @@ image-$(CONFIG_PPC_CHRP) += zImage.chrp
|
|
image-$(CONFIG_PPC_EFIKA) += zImage.chrp
|
|
image-$(CONFIG_PPC_PMAC) += zImage.pmac
|
|
image-$(CONFIG_PPC_HOLLY) += dtbImage.holly
|
|
-image-$(CONFIG_DEFAULT_UIMAGE) += uImage
|
|
image-$(CONFIG_EPAPR_BOOT) += zImage.epapr
|
|
|
|
#
|
|
@@ -421,15 +420,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
|
|
$(obj)/vmlinux.strip: vmlinux
|
|
$(STRIP) -s -R .comment $< -o $@
|
|
|
|
-$(obj)/uImage: vmlinux $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot)
|
|
-
|
|
-$(obj)/uImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
|
|
-
|
|
-$(obj)/uImage.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
- $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb)
|
|
-
|
|
$(obj)/cuImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
|
|
$(call if_changed,wrap,cuboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
|
|
|