mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-23 15:32:33 +00:00
7d768a9ba6
Add a universal zImage which can be loaded by mpc85xx boards at load address 0x3000000. This allows boards to boot kernels larger than 16MB even if the image is loaded temporarily from NAND at offset 0x1000000 which some bootloaders do by default. Signed-off-by: David Bauer <mail@david-bauer.net>
41 lines
1.4 KiB
Diff
41 lines
1.4 KiB
Diff
From b30ba76a980b3a9282f309c23e3bb0b0eb2c72cd Mon Sep 17 00:00:00 2001
|
|
From: David Bauer <mail@david-bauer.net>
|
|
Date: Thu, 30 May 2024 02:55:38 +0200
|
|
Subject: [PATCH] powerpc: add compressed zImage for mpc85xx
|
|
|
|
Add a universal zImage which can be loaded by mpc85xx boards at
|
|
load address 0x3000000. This allows boards to boot kernels larger than
|
|
16MB even if the image is loaded temporarily from NAND at offset
|
|
0x1000000 which some bootloaders do by default.
|
|
|
|
Signed-off-by: David Bauer <mail@david-bauer.net>
|
|
---
|
|
arch/powerpc/boot/Makefile | 1 +
|
|
arch/powerpc/boot/wrapper | 5 +++++
|
|
2 files changed, 6 insertions(+)
|
|
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -345,6 +345,7 @@ image-$(CONFIG_MPC836x_MDS) += cuImage.
|
|
image-$(CONFIG_ASP834x) += dtbImage.asp834x-redboot
|
|
|
|
# Board ports in arch/powerpc/platform/85xx/Kconfig
|
|
+image-y += zImage.la3000000
|
|
image-$(CONFIG_MPC8540_ADS) += cuImage.mpc8540ads
|
|
image-$(CONFIG_MPC8560_ADS) += cuImage.mpc8560ads
|
|
image-$(CONFIG_MPC85xx_CDS) += cuImage.mpc8541cds \
|
|
--- a/arch/powerpc/boot/wrapper
|
|
+++ b/arch/powerpc/boot/wrapper
|
|
@@ -254,6 +254,11 @@ if [ -n "$esm_blob" -a "$platform" != "p
|
|
fi
|
|
|
|
case "$platform" in
|
|
+la3000000)
|
|
+ binary=y
|
|
+ platformo="$object/fixed-head.o $object/of.o $object/epapr.o"
|
|
+ link_address='0x3000000'
|
|
+ ;;
|
|
of)
|
|
platformo="$object/of.o $object/epapr.o"
|
|
make_space=n
|