mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 23:12:32 +00:00
e4d061cd1a
with u-boot v2020.07 some variables have been renamed so this patch needs to be adjusted
otherwise at least with macOS as build system there are build errors
Signed-off-by: Ronny Kotzschmar <ro.ok@me.com>
(cherry picked from commit 547a932ee9
)
17 lines
471 B
Diff
17 lines
471 B
Diff
--- a/tools/env/Makefile
|
|
+++ b/tools/env/Makefile
|
|
@@ -8,6 +8,13 @@
|
|
# with "CC" here for the maximum code reuse of scripts/Makefile.host.
|
|
override HOSTCC = $(CC)
|
|
|
|
+ifneq ($(TARGET_CFLAGS),)
|
|
+KBUILD_HOSTCFLAGS = $(TARGET_CFLAGS)
|
|
+endif
|
|
+ifneq ($(TARGET_LDFLAGS),)
|
|
+KBUILD_HOSTLDFLAGS = $(TARGET_LDFLAGS)
|
|
+endif
|
|
+
|
|
# Compile for a hosted environment on the target
|
|
HOST_EXTRACFLAGS = -I$(srctree)/tools \
|
|
$(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
|