mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 08:51:13 +00:00
6bbca3a09a
This adds the default-state = "on"; statement for the power or primary status LED in DTS on kirkwood. This will ensure that this LED will be lit up very early in the boot process (i.e. before diag.sh is executed) and thus will provide an additional hint to the user when problems arise during early boot process. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
138 lines
2.8 KiB
Diff
138 lines
2.8 KiB
Diff
--- a/arch/arm/boot/dts/Makefile
|
|
+++ b/arch/arm/boot/dts/Makefile
|
|
@@ -237,6 +237,7 @@ dtb-$(CONFIG_MACH_KIRKWOOD) += \
|
|
kirkwood-ds411.dtb \
|
|
kirkwood-ds411j.dtb \
|
|
kirkwood-ds411slim.dtb \
|
|
+ kirkwood-goflexhome.dtb \
|
|
kirkwood-goflexnet.dtb \
|
|
kirkwood-guruplug-server-plus.dtb \
|
|
kirkwood-ib62x0.dtb \
|
|
--- /dev/null
|
|
+++ b/arch/arm/boot/dts/kirkwood-goflexhome.dts
|
|
@@ -0,0 +1,124 @@
|
|
+/dts-v1/;
|
|
+
|
|
+#include "kirkwood.dtsi"
|
|
+#include "kirkwood-6281.dtsi"
|
|
+
|
|
+/ {
|
|
+ model = "Seagate GoFlex Home";
|
|
+ compatible = "seagate,goflexhome", "marvell,kirkwood-88f6281", "marvell,kirkwood";
|
|
+
|
|
+ aliases {
|
|
+ led-boot = &led_health;
|
|
+ led-failsafe = &led_fault;
|
|
+ led-running = &led_health;
|
|
+ led-upgrade = &led_fault;
|
|
+ };
|
|
+
|
|
+ memory {
|
|
+ device_type = "memory";
|
|
+ reg = <0x00000000 0x8000000>;
|
|
+ };
|
|
+
|
|
+ chosen {
|
|
+ bootargs = "console=ttyS0,115200n8 earlyprintk root=/dev/sda1 rootdelay=10";
|
|
+ stdout-path = &uart0;
|
|
+ };
|
|
+
|
|
+ ocp@f1000000 {
|
|
+ pinctrl: pin-controller@10000 {
|
|
+ pmx_usb_power_enable: pmx-usb-power-enable {
|
|
+ marvell,pins = "mpp29";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ pmx_led_white: pmx-led-white {
|
|
+ marvell,pins = "mpp40";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ pmx_led_green: pmx-led_green {
|
|
+ marvell,pins = "mpp46";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ pmx_led_orange: pmx-led-orange {
|
|
+ marvell,pins = "mpp47";
|
|
+ marvell,function = "gpio";
|
|
+ };
|
|
+ };
|
|
+ serial@12000 {
|
|
+ status = "ok";
|
|
+ };
|
|
+
|
|
+ sata@80000 {
|
|
+ status = "okay";
|
|
+ nr-ports = <2>;
|
|
+ };
|
|
+
|
|
+ };
|
|
+ gpio-leds {
|
|
+ compatible = "gpio-leds";
|
|
+
|
|
+ led_health: health {
|
|
+ label = "status:green:health";
|
|
+ gpios = <&gpio1 14 GPIO_ACTIVE_LOW>;
|
|
+ default-state = "on";
|
|
+ };
|
|
+ led_fault: fault {
|
|
+ label = "status:orange:fault";
|
|
+ gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
|
|
+ };
|
|
+ misc {
|
|
+ label = "status:white:misc";
|
|
+ gpios = <&gpio1 8 GPIO_ACTIVE_LOW>;
|
|
+ linux,default-trigger = "disk-activity";
|
|
+ };
|
|
+ };
|
|
+ regulators {
|
|
+ compatible = "simple-bus";
|
|
+ #address-cells = <1>;
|
|
+ #size-cells = <0>;
|
|
+ pinctrl-0 = <&pmx_usb_power_enable>;
|
|
+ pinctrl-names = "default";
|
|
+
|
|
+ usb_power: regulator@1 {
|
|
+ compatible = "regulator-fixed";
|
|
+ reg = <1>;
|
|
+ regulator-name = "USB Power";
|
|
+ regulator-min-microvolt = <5000000>;
|
|
+ regulator-max-microvolt = <5000000>;
|
|
+ enable-active-high;
|
|
+ regulator-always-on;
|
|
+ regulator-boot-on;
|
|
+ gpio = <&gpio0 29 GPIO_ACTIVE_HIGH>;
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
+&nand {
|
|
+ chip-delay = <40>;
|
|
+ status = "okay";
|
|
+
|
|
+ partition@0 {
|
|
+ label = "u-boot";
|
|
+ reg = <0x0000000 0x100000>;
|
|
+ read-only;
|
|
+ };
|
|
+
|
|
+ partition@100000 {
|
|
+ label = "ubi";
|
|
+ reg = <0x100000 0x0ff00000>;
|
|
+ };
|
|
+};
|
|
+
|
|
+&mdio {
|
|
+ status = "okay";
|
|
+
|
|
+ ethphy0: ethernet-phy@0 {
|
|
+ reg = <0>;
|
|
+ };
|
|
+};
|
|
+
|
|
+ð0 {
|
|
+ status = "okay";
|
|
+ ethernet0-port@0 {
|
|
+ phy-handle = <ðphy0>;
|
|
+ };
|
|
+};
|