mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
3771176c9e
The following patches are dropped because they are merged upstream: -0001-tty-serial-drop-QCA-pecific-SoC-symbols.patch -0006-usb-drop-deprecated-symbols.patch -0009-MIPS-ath79-add-lots-of-missing-registers.patch -0010-MIPS-ath79-add-support-for-QCA953x-QCA956x-TP9343.patch -0014-MIPS-ath79-finetune-cpu-overrides.patch -0015-MIPS-ath79-enable-uart-during-early_prink.patch -0016-MIPS-ath79-get-PCIe-controller-out-of-reset.patch This patch is dropped due to the introduction of spi-mem framework: -461-spi-ath79-add-fast-flash-read.patch Thank to Michael Marley @mamarley for his work on this patch: -910-unaligned_access_hacks.patch Signed-off-by: Chuanhong Guo <gch981213@gmail.com> [synchronized kernel config with make kernel_oldconfig] Signed-off-by: Petr Štetiar <ynezz@true.cz>
21 lines
781 B
Diff
21 lines
781 B
Diff
--- a/drivers/mtd/parsers/Makefile
|
|
+++ b/drivers/mtd/parsers/Makefile
|
|
@@ -1,2 +1,3 @@
|
|
+obj-$(CONFIG_MTD_PARSER_CYBERTAN) += parser_cybertan.o
|
|
obj-$(CONFIG_MTD_PARSER_TRX) += parser_trx.o
|
|
obj-$(CONFIG_MTD_SHARPSL_PARTS) += sharpslpart.o
|
|
--- a/drivers/mtd/parsers/Kconfig
|
|
+++ b/drivers/mtd/parsers/Kconfig
|
|
@@ -1,3 +1,11 @@
|
|
+config MTD_PARSER_CYBERTAN
|
|
+ tristate "Parser for Cybertan format partitions"
|
|
+ depends on MTD && (ATH79 || COMPILE_TEST)
|
|
+ help
|
|
+ Cybertan has a proprietory header than encompasses a Broadcom trx
|
|
+ header. This driver will parse the header and take care of the
|
|
+ special offsets that result in the extra headers.
|
|
+
|
|
config MTD_PARSER_TRX
|
|
tristate "Parser for TRX format partitions"
|
|
depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)
|