mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 06:57:57 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
85 lines
2.2 KiB
Diff
85 lines
2.2 KiB
Diff
From 3b1653188f0b0832290dffe6b472d71b546231e1 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Sat, 12 May 2018 21:35:43 +0100
|
|
Subject: [PATCH] firmware/raspberrypi: Notify firmware of a reboot
|
|
|
|
Register for reboot notifications, sending RPI_FIRMWARE_NOTIFY_REBOOT
|
|
over the mailbox interface on reception.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
drivers/firmware/raspberrypi.c | 40 +++++++++++++++++++++++++++++++++-
|
|
1 file changed, 39 insertions(+), 1 deletion(-)
|
|
|
|
--- a/drivers/firmware/raspberrypi.c
|
|
+++ b/drivers/firmware/raspberrypi.c
|
|
@@ -12,6 +12,7 @@
|
|
#include <linux/module.h>
|
|
#include <linux/of_platform.h>
|
|
#include <linux/platform_device.h>
|
|
+#include <linux/reboot.h>
|
|
#include <linux/slab.h>
|
|
#include <soc/bcm2835/raspberrypi-firmware.h>
|
|
|
|
@@ -179,6 +180,26 @@ int rpi_firmware_property(struct rpi_fir
|
|
}
|
|
EXPORT_SYMBOL_GPL(rpi_firmware_property);
|
|
|
|
+static int rpi_firmware_notify_reboot(struct notifier_block *nb,
|
|
+ unsigned long action,
|
|
+ void *data)
|
|
+{
|
|
+ struct rpi_firmware *fw;
|
|
+ struct platform_device *pdev = g_pdev;
|
|
+
|
|
+ if (!pdev)
|
|
+ return 0;
|
|
+
|
|
+ fw = platform_get_drvdata(pdev);
|
|
+ if (!fw)
|
|
+ return 0;
|
|
+
|
|
+ (void)rpi_firmware_property(fw, RPI_FIRMWARE_NOTIFY_REBOOT,
|
|
+ 0, 0);
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
static void
|
|
rpi_firmware_print_firmware_revision(struct rpi_firmware *fw)
|
|
{
|
|
@@ -387,15 +408,32 @@ static struct platform_driver rpi_firmwa
|
|
.remove = rpi_firmware_remove,
|
|
};
|
|
|
|
+static struct notifier_block rpi_firmware_reboot_notifier = {
|
|
+ .notifier_call = rpi_firmware_notify_reboot,
|
|
+};
|
|
+
|
|
static int __init rpi_firmware_init(void)
|
|
{
|
|
- return platform_driver_register(&rpi_firmware_driver);
|
|
+ int ret = register_reboot_notifier(&rpi_firmware_reboot_notifier);
|
|
+ if (ret)
|
|
+ goto out1;
|
|
+ ret = platform_driver_register(&rpi_firmware_driver);
|
|
+ if (ret)
|
|
+ goto out2;
|
|
+
|
|
+ return 0;
|
|
+
|
|
+out2:
|
|
+ unregister_reboot_notifier(&rpi_firmware_reboot_notifier);
|
|
+out1:
|
|
+ return ret;
|
|
}
|
|
subsys_initcall(rpi_firmware_init);
|
|
|
|
static void __init rpi_firmware_exit(void)
|
|
{
|
|
platform_driver_unregister(&rpi_firmware_driver);
|
|
+ unregister_reboot_notifier(&rpi_firmware_reboot_notifier);
|
|
}
|
|
module_exit(rpi_firmware_exit);
|
|
|