mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 08:51:13 +00:00
df8e6be59a
This adds support for the RTL838x Architecture. SoCs of this type are used in managed and un-managed Switches and Routers with 8-28 ports. Drivers are provided for SoC initialization, GPIOs, Flash, Ethernet including a DSA switch driver and internal and external PHYs used with these switches. Supported SoCs: RTL8380M RTL8381M RTL8382M The kernel will also boot on the following RTL839x SoCs, however driver support apart from spi-nor is missing: RTL8390 RTL8391 RTL8393 The following PHYs are supported: RTL8214FC (Quad QSGMII multiplexing GMAC and SFP port) RTL8218B internal: internal PHY of the RTL838x chips RTL8318b external (QSGMII 8-port GMAC phy) RTL8382M SerDes for 2 SFP ports Initialization sequences for the PHYs are provided in the form of firmware files. Flash driver supports 3 / 4 byte access DSA switch driver supports VLANs, port isolation, STP and port mirroring. The ALLNET ALL-SG8208M is supported as Proof of Concept: RTL8382M SoC 1 MIPS 4KEc core @ 500MHz 8 Internal PHYs (RTL8218B) 128MB DRAM (Nanya NT5TU128MB) 16MB NOR Flash (MXIC 25L128) 8 GBEthernet ports with one green status LED each (SoC controlled) 1 Power LED (not configurable) 1 SYS LED (configurable) 1 On-Off switch (not configurable) 1 Reset button at the right behind right air-vent (not configurable) 1 Reset button on front panel (configurable) 12V 1A barrel connector 1 serial header with populated standard pin connector and with markings GND TX RX Vcc(3.3V), connection properties: 115200 8N1 To install, upload the sysupgrade image to the OEM webpage. Signed-off-by: Birger Koblitz <git@birger-koblitz.de>
27 lines
1018 B
Diff
27 lines
1018 B
Diff
--- a/drivers/net/ethernet/Kconfig
|
|
+++ b/drivers/net/ethernet/Kconfig
|
|
@@ -163,6 +163,13 @@ source "drivers/net/ethernet/rdc/Kconfig
|
|
source "drivers/net/ethernet/realtek/Kconfig"
|
|
source "drivers/net/ethernet/renesas/Kconfig"
|
|
source "drivers/net/ethernet/rocker/Kconfig"
|
|
+
|
|
+config NET_RTL838X
|
|
+ tristate "Realtek rtl838x Ethernet MAC support"
|
|
+ depends on RTL838X
|
|
+ ---help---
|
|
+ Say Y here if you want to use the Realtek rtl838x Gbps Ethernet MAC.
|
|
+
|
|
source "drivers/net/ethernet/samsung/Kconfig"
|
|
source "drivers/net/ethernet/seeq/Kconfig"
|
|
source "drivers/net/ethernet/sfc/Kconfig"
|
|
--- a/drivers/net/ethernet/Makefile
|
|
+++ b/drivers/net/ethernet/Makefile
|
|
@@ -76,6 +76,7 @@ obj-$(CONFIG_NET_VENDOR_REALTEK) += real
|
|
obj-$(CONFIG_NET_VENDOR_RENESAS) += renesas/
|
|
obj-$(CONFIG_NET_VENDOR_RDC) += rdc/
|
|
obj-$(CONFIG_NET_VENDOR_ROCKER) += rocker/
|
|
+obj-$(CONFIG_NET_RTL838X) += rtl838x_eth.o
|
|
obj-$(CONFIG_NET_VENDOR_SAMSUNG) += samsung/
|
|
obj-$(CONFIG_NET_VENDOR_SEEQ) += seeq/
|
|
obj-$(CONFIG_NET_VENDOR_SILAN) += silan/
|