mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 08:51:13 +00:00
770a9c6787
All modifications made by update_kernel.sh/no manual intervention needed Run-tested: ipq806x (R7800), ath79 (Archer C7v5), x86/64 No dmesg regressions, everything appears functional Signed-off-by: John Audia <graysky@archlinux.us> [add run test from PR] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
27 lines
974 B
Diff
27 lines
974 B
Diff
--- a/drivers/net/dsa/Kconfig
|
|
+++ b/drivers/net/dsa/Kconfig
|
|
@@ -75,6 +75,13 @@ config NET_DSA_REALTEK_SMI
|
|
This enables support for the Realtek SMI-based switch
|
|
chips, currently only RTL8366RB.
|
|
|
|
+config NET_DSA_RTL838X
|
|
+ tristate "Realtek rtl838x switch support"
|
|
+ depends on RTL838X
|
|
+ select NET_DSA_TAG_TRAILER
|
|
+ ---help---
|
|
+ Say Y here if you want to use the Realtek rtl838x switch.
|
|
+
|
|
config NET_DSA_SMSC_LAN9303
|
|
tristate
|
|
select NET_DSA_TAG_LAN9303
|
|
--- a/drivers/net/dsa/Makefile
|
|
+++ b/drivers/net/dsa/Makefile
|
|
@@ -11,6 +11,7 @@ obj-$(CONFIG_NET_DSA_MV88E6060) += mv88e
|
|
obj-$(CONFIG_NET_DSA_QCA8K) += qca8k.o
|
|
obj-$(CONFIG_NET_DSA_REALTEK_SMI) += realtek-smi.o
|
|
realtek-smi-objs := realtek-smi-core.o rtl8366.o rtl8366rb.o
|
|
+obj-$(CONFIG_NET_DSA_RTL838X) += rtl838x_sw.o rtl838x_phy.o
|
|
obj-$(CONFIG_NET_DSA_SMSC_LAN9303) += lan9303-core.o
|
|
obj-$(CONFIG_NET_DSA_SMSC_LAN9303_I2C) += lan9303_i2c.o
|
|
obj-$(CONFIG_NET_DSA_SMSC_LAN9303_MDIO) += lan9303_mdio.o
|