mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 01:28:59 +00:00
bcaabe6d05
Similar version was upstreamed: bcm27xx/patches-5.4/950-0392-tty-amba-pl011-Add-un-throttle-support.patch Manually adapted: ipq806x/patches-5.4/0063-2-tsens-support-configurable-interrupts.patch layerscape/patches-5.4/301-arch-0008-arm-add-new-non-shareable-ioremap.patch Compile-tested: x86/64 Run-tested: x86/64 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
30 lines
889 B
Diff
30 lines
889 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -826,6 +826,16 @@ config LEDS_LM36274
|
|
|
|
source "drivers/leds/blink/Kconfig"
|
|
|
|
+config LEDS_UBNT_LEDBAR
|
|
+ tristate "LED support for Ubiquiti UniFi 6 LR"
|
|
+ depends on LEDS_CLASS && I2C && OF
|
|
+ help
|
|
+ This option enables support for the Ubiquiti LEDBAR
|
|
+ LED driver.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module
|
|
+ will be called leds-ubnt-ledbar.
|
|
+
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -85,6 +85,7 @@ obj-$(CONFIG_LEDS_LM3601X) += leds-lm36
|
|
obj-$(CONFIG_LEDS_TI_LMU_COMMON) += leds-ti-lmu-common.o
|
|
obj-$(CONFIG_LEDS_LM3697) += leds-lm3697.o
|
|
obj-$(CONFIG_LEDS_LM36274) += leds-lm36274.o
|
|
+obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
|
|
|
|
# LED SPI Drivers
|
|
obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o
|