mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-29 10:08:59 +00:00
ca5c695a45
Deleted following upstreamed patches: bcm27xx: 950-0006-drm-vc4-hdmi-Fix-HPD-GPIO-detection.patch bcm27xx: 950-0420-drm-vc4-Adopt-the-dma-configuration-from-the-HVS-or-.patch bcm27xx: 950-0425-drm-vc4-A-present-but-empty-dmas-disables-audio.patch bcm27xx: 950-0432-vc4-drm-Avoid-full-hdmi-audio-fifo-writes.patch bcm27xx: 950-0433-vc4-drm-vc4_plane-Remove-subpixel-positioning-check.patch bcm27xx: 950-0435-drm-vc4-Correct-pixel-order-for-DSI0.patch bcm27xx: 950-0436-drm-vc4-Register-dsi0-as-the-correct-vc4-encoder-typ.patch bcm27xx: 950-0437-drm-vc4-Fix-dsi0-interrupt-support.patch bcm27xx: 950-0438-drm-vc4-Add-correct-stop-condition-to-vc4_dsi_encode.patch bcm27xx: 950-0443-drm-vc4-Fix-timings-for-interlaced-modes.patch bcm27xx: 950-0445-drm-vc4-Fix-margin-calculations-for-the-right-bottom.patch bcm27xx: 950-0475-drm-vc4-Reset-HDMI-MISC_CONTROL-register.patch bcm27xx: 950-0476-drm-vc4-Release-workaround-buffer-and-DMA-in-error-p.patch bcm27xx: 950-0477-drm-vc4-Correct-DSI-divider-calculations.patch bcm27xx: 950-0664-drm-vc4-dsi-Correct-max-divider-to-255-not-7.patch bcm53xx: 072-next-ARM_dts_BCM53015-add-mr26.patch mediatek: 920-linux-next-dts-mt7622-bpi-r64-fix-wps-button.patch Manually rebased following patches: bcm27xx: 950-0004-drm-vc4-hdmi-Remove-the-DDC-probing-for-status-detec.patch bcm27xx: 950-0700-net-phy-lan87xx-Decrease-phy-polling-rate.patch bcm27xx: 950-0711-drm-vc4-Rename-bridge-to-out_bridge.patch bcm27xx: 950-0713-drm-vc4-Remove-splitting-the-bridge-chain-from-the-d.patch bcm27xx: 950-0715-drm-vc4-Convert-vc4_dsi-to-using-a-bridge-instead-of.patch bcm27xx: 950-0787-vc4-drm-vc4_plane-Keep-fractional-source-coords-insi.patch bcm27xx: 950-0914-mmc-block-Don-t-do-single-sector-reads-during-recove.patch Runtime tested on turris-omnia and glinet-b1300. Tested-by: John Audia <therealgraysky@proton.me> [bcm2711/RPi4B, mt7622/RT3200] Signed-off-by: Petr Štetiar <ynezz@true.cz>
93 lines
2.9 KiB
Diff
93 lines
2.9 KiB
Diff
From e3692cb2fcd5ba1244512a0f43b8118f65f1c375 Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Sat, 8 Jul 2017 08:20:43 +0200
|
|
Subject: debloat: dmabuf
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
drivers/base/Kconfig | 2 +-
|
|
drivers/dma-buf/Makefile | 10 +++++++---
|
|
drivers/dma-buf/dma-buf.c | 4 +++-
|
|
kernel/sched/core.c | 1 +
|
|
4 files changed, 12 insertions(+), 5 deletions(-)
|
|
|
|
--- a/drivers/base/Kconfig
|
|
+++ b/drivers/base/Kconfig
|
|
@@ -187,7 +187,7 @@ config SOC_BUS
|
|
source "drivers/base/regmap/Kconfig"
|
|
|
|
config DMA_SHARED_BUFFER
|
|
- bool
|
|
+ tristate
|
|
default n
|
|
select IRQ_WORK
|
|
help
|
|
--- a/drivers/dma-buf/heaps/Makefile
|
|
+++ b/drivers/dma-buf/heaps/Makefile
|
|
@@ -1,3 +1,3 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
-obj-$(CONFIG_DMABUF_HEAPS_SYSTEM) += system_heap.o
|
|
-obj-$(CONFIG_DMABUF_HEAPS_CMA) += cma_heap.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_HEAPS_SYSTEM) += system_heap.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_HEAPS_CMA) += cma_heap.o
|
|
--- a/drivers/dma-buf/Makefile
|
|
+++ b/drivers/dma-buf/Makefile
|
|
@@ -1,16 +1,20 @@
|
|
# SPDX-License-Identifier: GPL-2.0-only
|
|
-obj-y := dma-buf.o dma-fence.o dma-fence-array.o dma-fence-chain.o \
|
|
+obj-$(CONFIG_DMA_SHARED_BUFFER) := dma-shared-buffer.o
|
|
+
|
|
+dma-buf-objs-y := dma-buf.o dma-fence.o dma-fence-array.o dma-fence-chain.o \
|
|
dma-resv.o seqno-fence.o
|
|
-obj-$(CONFIG_DMABUF_HEAPS) += dma-heap.o
|
|
-obj-$(CONFIG_DMABUF_HEAPS) += heaps/
|
|
-obj-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
-obj-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
-obj-$(CONFIG_UDMABUF) += udmabuf.o
|
|
-obj-$(CONFIG_DMABUF_SYSFS_STATS) += dma-buf-sysfs-stats.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_HEAPS) += dma-heap.o
|
|
+obj-$(CONFIG_DMABUF_HEAPS) += heaps/
|
|
+dma-buf-objs-$(CONFIG_SYNC_FILE) += sync_file.o
|
|
+dma-buf-objs-$(CONFIG_SW_SYNC) += sw_sync.o sync_debug.o
|
|
+dma-buf-objs-$(CONFIG_UDMABUF) += udmabuf.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_SYSFS_STATS) += udmabuf.o
|
|
|
|
dmabuf_selftests-y := \
|
|
selftest.o \
|
|
st-dma-fence.o \
|
|
st-dma-fence-chain.o
|
|
|
|
-obj-$(CONFIG_DMABUF_SELFTESTS) += dmabuf_selftests.o
|
|
+dma-buf-objs-$(CONFIG_DMABUF_SELFTESTS) += dmabuf_selftests.o
|
|
+
|
|
+dma-shared-buffer-objs := $(dma-buf-objs-y)
|
|
--- a/drivers/dma-buf/dma-buf.c
|
|
+++ b/drivers/dma-buf/dma-buf.c
|
|
@@ -1513,4 +1513,5 @@ static void __exit dma_buf_deinit(void)
|
|
kern_unmount(dma_buf_mnt);
|
|
dma_buf_uninit_sysfs_statistics();
|
|
}
|
|
-__exitcall(dma_buf_deinit);
|
|
+module_exit(dma_buf_deinit);
|
|
+MODULE_LICENSE("GPL");
|
|
--- a/kernel/sched/core.c
|
|
+++ b/kernel/sched/core.c
|
|
@@ -4184,6 +4184,7 @@ int wake_up_state(struct task_struct *p,
|
|
{
|
|
return try_to_wake_up(p, state, 0);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(wake_up_state);
|
|
|
|
/*
|
|
* Perform scheduler related setup for a newly forked process p.
|
|
--- a/fs/d_path.c
|
|
+++ b/fs/d_path.c
|
|
@@ -316,6 +316,7 @@ char *dynamic_dname(struct dentry *dentr
|
|
buffer += buflen - sz;
|
|
return memcpy(buffer, temp, sz);
|
|
}
|
|
+EXPORT_SYMBOL_GPL(dynamic_dname);
|
|
|
|
char *simple_dname(struct dentry *dentry, char *buffer, int buflen)
|
|
{
|