mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-27 09:12:39 +00:00
7bf62e2451
All patches automatically rebased.
Build system: x86_64
Build-tested: ramips/mt7621*
*Had to revert 7f1edbd
in order to build due to FS#4149
Signed-off-by: John Audia <graysky@archlinux.us>
26 lines
794 B
Diff
26 lines
794 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -536,6 +536,12 @@ config REALTEK_PHY
|
|
---help---
|
|
Supports the Realtek 821x PHY.
|
|
|
|
+config REALTEK_SOC_PHY
|
|
+ tristate "Realtek SoC PHYs"
|
|
+ depends on RTL838X
|
|
+ ---help---
|
|
+ Supports the PHYs found in combination with Realtek Switch SoCs
|
|
+
|
|
config RENESAS_PHY
|
|
tristate "Driver for Renesas PHYs"
|
|
---help---
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -101,6 +101,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
|
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_REALTEK_SOC_PHY) += rtl83xx-phy.o
|
|
obj-$(CONFIG_RENESAS_PHY) += uPD60620.o
|
|
obj-$(CONFIG_ROCKCHIP_PHY) += rockchip.o
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|