mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-30 10:39:04 +00:00
74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
82 lines
2.7 KiB
Diff
82 lines
2.7 KiB
Diff
From: Alexey Brodkin <abrodkin@synopsys.com>
|
|
Subject: usb: Remove annoying warning about bogus URB
|
|
|
|
When ath9k-htc Wi-Fi dongle is used with generic OHCI controller
|
|
infinite stream of warnings appears in debug console like this:
|
|
-------------------------->8----------------------
|
|
usb 1-1: new full-speed USB device number 2 using ohci-platform
|
|
usb 1-1: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
|
|
usb 1-1: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size:
|
|
51008
|
|
------------[ cut here ]------------
|
|
WARNING: CPU: 0 PID: 19 at drivers/usb/core/urb.c:449
|
|
usb_submit_urb+0x1b4/0x498()
|
|
usb 1-1: BOGUS urb xfer, pipe 1 != type 3
|
|
Modules linked in:
|
|
CPU: 0 PID: 19 Comm: kworker/0:1 Not tainted
|
|
4.4.0-rc4-00017-g00e2d79-dirty #3
|
|
Workqueue: events request_firmware_work_func
|
|
|
|
Stack Trace:
|
|
arc_unwind_core.constprop.1+0xa4/0x110
|
|
---[ end trace 649ef8c342817fc2 ]---
|
|
------------[ cut here ]------------
|
|
WARNING: CPU: 0 PID: 19 at drivers/usb/core/urb.c:449
|
|
usb_submit_urb+0x1b4/0x498()
|
|
usb 1-1: BOGUS urb xfer, pipe 1 != type 3
|
|
Modules linked in:
|
|
CPU: 0 PID: 19 Comm: kworker/0:1 Tainted: G W
|
|
4.4.0-rc4-00017-g00e2d79-dirty #3
|
|
Workqueue: events request_firmware_work_func
|
|
|
|
Stack Trace:
|
|
arc_unwind_core.constprop.1+0xa4/0x110
|
|
---[ end trace 649ef8c342817fc3 ]---
|
|
------------[ cut here ]------------
|
|
-------------------------->8----------------------
|
|
|
|
There're some discussions in mailing lists proposing to disable
|
|
that particular check alltogether and magically all seem to work
|
|
fine with muted warning.
|
|
|
|
Anyways new thread on that regard could be found here:
|
|
http://lists.infradead.org/pipermail/linux-snps-arc/2016-July/001310.html
|
|
|
|
Let's see what comes out of that new discussion, hopefully patching
|
|
of generic USB stuff won't be required then.
|
|
|
|
Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
|
|
---
|
|
drivers/leds/Makefile | 1 +
|
|
drivers/leds/trigger/Kconfig | 7 +++++++
|
|
2 files changed, 8 insertions(+)
|
|
|
|
diff --git a/drivers/leds/Makefile b/drivers/leds/Makefile
|
|
index 3965070190f5..6273d7e29eab 100644
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -77,3 +77,4 @@ obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|
|
|
|
# LED Triggers
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += trigger/
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|
|
diff --git a/drivers/leds/trigger/Kconfig b/drivers/leds/trigger/Kconfig
|
|
index 3f9ddb9fafa7..4ec185389324 100644
|
|
--- a/drivers/leds/trigger/Kconfig
|
|
+++ b/drivers/leds/trigger/Kconfig
|
|
@@ -126,4 +126,11 @@ config LEDS_TRIGGER_PANIC
|
|
a different trigger.
|
|
If unsure, say Y.
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on NET && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # LEDS_TRIGGERS
|
|
--
|
|
2.11.0
|
|
|