mirror of
https://github.com/openwrt/openwrt.git
synced 2025-03-11 06:54:21 +00:00
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From: Gabor Juhos <juhosg@openwrt.org>
|
|
Subject: [PATCH] kernel/3.10: move squashfs check from rootfs split code into a separate file
|
|
|
|
lede-commit: d89bea92b31b4e157a0fa438e75370f089f73427
|
|
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
|
|
---
|
|
drivers/mtd/Kconfig | 2 ++
|
|
drivers/mtd/Makefile | 2 ++
|
|
2 files changed, 4 insertions(+)
|
|
|
|
diff --git a/drivers/mtd/Kconfig b/drivers/mtd/Kconfig
|
|
index f5ac04e288eb..4185e04760dd 100644
|
|
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -27,6 +27,8 @@ config MTD_SPLIT_FIRMWARE_NAME
|
|
depends on MTD_SPLIT_FIRMWARE
|
|
default "firmware"
|
|
|
|
+source "drivers/mtd/mtdsplit/Kconfig"
|
|
+
|
|
endmenu
|
|
|
|
config MTD_TESTS
|
|
diff --git a/drivers/mtd/Makefile b/drivers/mtd/Makefile
|
|
index 151d60df303a..48fd01e9f6e3 100644
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -6,6 +6,8 @@
|
|
obj-$(CONFIG_MTD) += mtd.o
|
|
mtd-y := mtdcore.o mtdsuper.o mtdconcat.o mtdpart.o mtdchar.o
|
|
|
|
+obj-$(CONFIG_MTD_SPLIT) += mtdsplit/
|
|
+
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
--
|
|
2.11.0
|
|
|