mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
113 lines
3.2 KiB
Diff
113 lines
3.2 KiB
Diff
From 3b6115d6b57a263bdc8c9b1df273bd4a7955eead Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Sat, 8 Jul 2017 08:16:31 +0200
|
|
Subject: debloat: add some debloat patches, strip down procfs and make O_DIRECT support optional, saves ~15K after lzma on MIPS
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
net/Kconfig | 3 +++
|
|
net/core/Makefile | 3 ++-
|
|
net/core/sock.c | 2 ++
|
|
net/ipv4/Kconfig | 1 +
|
|
net/netlink/Kconfig | 1 +
|
|
net/packet/Kconfig | 1 +
|
|
net/unix/Kconfig | 1 +
|
|
7 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/net/Kconfig b/net/Kconfig
|
|
index 38a0c857eb52..b4621e1f3470 100644
|
|
--- a/net/Kconfig
|
|
+++ b/net/Kconfig
|
|
@@ -95,6 +95,9 @@ source "net/netlabel/Kconfig"
|
|
|
|
endif # if INET
|
|
|
|
+config SOCK_DIAG
|
|
+ bool
|
|
+
|
|
config NETWORK_SECMARK
|
|
bool "Security Marking"
|
|
help
|
|
diff --git a/net/core/Makefile b/net/core/Makefile
|
|
index d6508c2ddca5..bee4adde14d8 100644
|
|
--- a/net/core/Makefile
|
|
+++ b/net/core/Makefile
|
|
@@ -9,8 +9,9 @@ obj-$(CONFIG_SYSCTL) += sysctl_net_core.o
|
|
|
|
obj-y += dev.o ethtool.o dev_addr_lists.o dst.o netevent.o \
|
|
neighbour.o rtnetlink.o utils.o link_watch.o filter.o \
|
|
- sock_diag.o dev_ioctl.o tso.o sock_reuseport.o
|
|
+ dev_ioctl.o tso.o sock_reuseport.o
|
|
|
|
+obj-$(CONFIG_SOCK_DIAG) += sock_diag.o
|
|
obj-$(CONFIG_XFRM) += flow.o
|
|
obj-y += net-sysfs.o
|
|
obj-$(CONFIG_PROC_FS) += net-procfs.o
|
|
diff --git a/net/core/sock.c b/net/core/sock.c
|
|
index 1989b3dd6d17..d4ca8db4166a 100644
|
|
--- a/net/core/sock.c
|
|
+++ b/net/core/sock.c
|
|
@@ -1457,9 +1457,11 @@ void sk_destruct(struct sock *sk)
|
|
|
|
static void __sk_free(struct sock *sk)
|
|
{
|
|
+#ifdef CONFIG_SOCK_DIAG
|
|
if (unlikely(sock_diag_has_destroy_listeners(sk) && sk->sk_net_refcnt))
|
|
sock_diag_broadcast_destroy(sk);
|
|
else
|
|
+#endif
|
|
sk_destruct(sk);
|
|
}
|
|
|
|
diff --git a/net/ipv4/Kconfig b/net/ipv4/Kconfig
|
|
index b54b3ca939db..74ecf598622c 100644
|
|
--- a/net/ipv4/Kconfig
|
|
+++ b/net/ipv4/Kconfig
|
|
@@ -408,6 +408,7 @@ config INET_XFRM_MODE_BEET
|
|
|
|
config INET_DIAG
|
|
tristate "INET: socket monitoring interface"
|
|
+ select SOCK_DIAG
|
|
default y
|
|
---help---
|
|
Support for INET (TCP, DCCP, etc) socket monitoring interface used by
|
|
diff --git a/net/netlink/Kconfig b/net/netlink/Kconfig
|
|
index 5d6e8c05b3d4..8a2696d66c20 100644
|
|
--- a/net/netlink/Kconfig
|
|
+++ b/net/netlink/Kconfig
|
|
@@ -4,6 +4,7 @@
|
|
|
|
config NETLINK_DIAG
|
|
tristate "NETLINK: socket monitoring interface"
|
|
+ select SOCK_DIAG
|
|
default n
|
|
---help---
|
|
Support for NETLINK socket monitoring interface used by the ss tool.
|
|
diff --git a/net/packet/Kconfig b/net/packet/Kconfig
|
|
index cc55b35f80e5..9a83c86f5480 100644
|
|
--- a/net/packet/Kconfig
|
|
+++ b/net/packet/Kconfig
|
|
@@ -18,6 +18,7 @@ config PACKET
|
|
config PACKET_DIAG
|
|
tristate "Packet: sockets monitoring interface"
|
|
depends on PACKET
|
|
+ select SOCK_DIAG
|
|
default n
|
|
---help---
|
|
Support for PF_PACKET sockets monitoring interface used by the ss tool.
|
|
diff --git a/net/unix/Kconfig b/net/unix/Kconfig
|
|
index 8b31ab85d050..6548cf3ea7f1 100644
|
|
--- a/net/unix/Kconfig
|
|
+++ b/net/unix/Kconfig
|
|
@@ -22,6 +22,7 @@ config UNIX
|
|
config UNIX_DIAG
|
|
tristate "UNIX: socket monitoring interface"
|
|
depends on UNIX
|
|
+ select SOCK_DIAG
|
|
default n
|
|
---help---
|
|
Support for UNIX socket monitoring interface used by the ss tool.
|
|
--
|
|
2.11.0
|
|
|