mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 06:33:41 +00:00
74d00a8c38
* properly format/comment all patches * merge debloat patches * merge Kconfig patches * merge swconfig patches * merge hotplug patches * drop 200-fix_localversion.patch - upstream * drop 222-arm_zimage_none.patch - unused * drop 252-mv_cesa_depends.patch - no longer required * drop 410-mtd-move-forward-declaration-of-struct-mtd_info.patch - unused * drop 661-fq_codel_keep_dropped_stats.patch - outdated * drop 702-phy_add_aneg_done_function.patch - upstream * drop 840-rtc7301.patch - unused * drop 841-rtc_pt7c4338.patch - upstream * drop 921-use_preinit_as_init.patch - unused * drop spio-gpio-old and gpio-mmc - unused Signed-off-by: John Crispin <john@phrozen.org>
32 lines
1.0 KiB
Diff
32 lines
1.0 KiB
Diff
From 107c0964cb8db7ca28ac5199426414fdab3c274d Mon Sep 17 00:00:00 2001
|
|
From: "Alexandros C. Couloumbis" <alex@ozo.com>
|
|
Date: Fri, 7 Jul 2017 17:14:51 +0200
|
|
Subject: hack: arch: powerpc: drop register save/restore library from modules
|
|
|
|
Upstream GCC uses a libgcc function for saving/restoring registers. This
|
|
makes the code bigger, and upstream kernels need to carry that function
|
|
for every single kernel module. Our GCC is patched to avoid those
|
|
references, so we can drop the extra bloat for modules.
|
|
|
|
lede-commit: e8e1084654f50904e6bf77b70b2de3f137d7b3ec
|
|
Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
|
|
---
|
|
arch/powerpc/Makefile | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
|
|
index 617dece67924..1146daa8e4c2 100644
|
|
--- a/arch/powerpc/Makefile
|
|
+++ b/arch/powerpc/Makefile
|
|
@@ -179,7 +179,6 @@ else
|
|
CHECKFLAGS += -D__LITTLE_ENDIAN__
|
|
endif
|
|
|
|
-KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
|
|
|
|
ifeq ($(CONFIG_476FPE_ERR46),y)
|
|
KBUILD_LDFLAGS_MODULE += --ppc476-workaround \
|
|
--
|
|
2.11.0
|
|
|