mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-21 22:47:56 +00:00
93ae4353cd
ath11k is the upstream driver for Qualcomm 802.11ax radios, both for the internal AHB and PCI based cards. This commit does however only provide PCI support while AHB will follow but its SoC specific so it will require an OpenWrt target first. It differs a bit from ath10k as it requires stuff like QRTR, MHI and QMI helpers. PCI variant requires qrtr-mhi and mhi-bus which backports do provide, however we are dropping those in a patch as they will conflict with support for the AHB variant as that one requires qrtr-smd which in turn requires RPMSG and GLINK and its not feasable to provide those in backports as they are really SoC specific. QRTR and MHI in kernel 5.10 are not usable and backporting the changes is not easy as they have changed drastically from 5.10 to 5.15 ath11k will only be available on targets that use kernel 5.15. Signed-off-by: Robert Marko <robimarko@gmail.com>
67 lines
2.4 KiB
Diff
67 lines
2.4 KiB
Diff
From 703d6551f71e7290619d6effe2a25a64e10538b7 Mon Sep 17 00:00:00 2001
|
|
From: Robert Marko <robimarko@gmail.com>
|
|
Date: Thu, 15 Dec 2022 12:20:52 +0100
|
|
Subject: [PATCH] ath11k: control thermal support via symbol
|
|
|
|
Currently, thermal support will get built if CONFIG_THERMAL is reachable,
|
|
however this is not suitable for OpenWrt as with ALL_KMODS being set to y
|
|
ATH11K_THERMAL wont get selected and so hwmon and thermal kmods wont get
|
|
pulled in resulting in a build-failure.
|
|
|
|
So, to avoid that, lets do what is already done for ath10k and add a
|
|
config symbol into backports for enabling thermal support.
|
|
|
|
Signed-off-by: Robert Marko <robimarko@gmail.com>
|
|
---
|
|
drivers/net/wireless/ath/ath11k/Kconfig | 7 +++++++
|
|
drivers/net/wireless/ath/ath11k/Makefile | 2 +-
|
|
drivers/net/wireless/ath/ath11k/thermal.h | 2 +-
|
|
local-symbols | 1 +
|
|
4 files changed, 10 insertions(+), 2 deletions(-)
|
|
|
|
--- a/drivers/net/wireless/ath/ath11k/Kconfig
|
|
+++ b/drivers/net/wireless/ath/ath11k/Kconfig
|
|
@@ -61,3 +61,10 @@ config ATH11K_SPECTRAL
|
|
Enable ath11k spectral scan support
|
|
|
|
Say Y to enable access to the FFT/spectral data via debugfs.
|
|
+
|
|
+config ATH11K_THERMAL
|
|
+ bool "ath11k thermal sensors and throttling support"
|
|
+ depends on ATH11K
|
|
+ depends on THERMAL
|
|
+ help
|
|
+ Enable ath11k thermal sensors and throttling support.
|
|
--- a/drivers/net/wireless/ath/ath11k/Makefile
|
|
+++ b/drivers/net/wireless/ath/ath11k/Makefile
|
|
@@ -22,7 +22,7 @@ ath11k-y += core.o \
|
|
ath11k-$(CPTCFG_ATH11K_DEBUGFS) += debugfs.o debugfs_htt_stats.o debugfs_sta.o
|
|
ath11k-$(CPTCFG_NL80211_TESTMODE) += testmode.o
|
|
ath11k-$(CPTCFG_ATH11K_TRACING) += trace.o
|
|
-ath11k-$(CONFIG_THERMAL) += thermal.o
|
|
+ath11k-$(CPTCFG_ATH11K_THERMAL) += thermal.o
|
|
ath11k-$(CPTCFG_ATH11K_SPECTRAL) += spectral.o
|
|
ath11k-$(CONFIG_PM) += wow.o
|
|
|
|
--- a/drivers/net/wireless/ath/ath11k/thermal.h
|
|
+++ b/drivers/net/wireless/ath/ath11k/thermal.h
|
|
@@ -25,7 +25,7 @@ struct ath11k_thermal {
|
|
int temperature;
|
|
};
|
|
|
|
-#if IS_REACHABLE(CONFIG_THERMAL)
|
|
+#if IS_REACHABLE(CPTCFG_ATH11K_THERMAL)
|
|
int ath11k_thermal_register(struct ath11k_base *sc);
|
|
void ath11k_thermal_unregister(struct ath11k_base *sc);
|
|
int ath11k_thermal_set_throttling(struct ath11k *ar, u32 throttle_state);
|
|
--- a/local-symbols
|
|
+++ b/local-symbols
|
|
@@ -174,6 +174,7 @@ ATH11K_DEBUG=
|
|
ATH11K_DEBUGFS=
|
|
ATH11K_TRACING=
|
|
ATH11K_SPECTRAL=
|
|
+ATH11K_THERMAL=
|
|
WLAN_VENDOR_ATMEL=
|
|
ATMEL=
|
|
PCI_ATMEL=
|