mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
738b04c881
Removed upstreamed:
pending-5.15/101-Use-stddefs.h-instead-of-compiler.h.patch[1]
ipq806x/patches-5.15/122-01-clk-qcom-clk-krait-fix-wrong-div2-functions.patch[2]
bcm27xx/patches-5.15/950-0198-drm-fourcc-Add-packed-10bit-YUV-4-2-0-format.patch[3]
Manually rebased:
ramips/patches-5.15/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch[4]
Added patch/backported:
ramips/patches-5.15/107-PCI-mt7621-Add-sentinel-to-quirks-table.patch[5]
All other patches automatically rebased.
1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=c160505c9b574b346031fdf2c649d19e7939ca11
2. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=a051e10bfc6906d29dae7a31f0773f2702edfe1b
3. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.15.86&id=ec1727f89ecd6f2252c0c75e200058819f7ce47a
4. Quilt gave this output when I applied the patch to rebase it:
% quilt push -f
Applying patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch
patching file arch/mips/ralink/Kconfig
patching file drivers/pci/controller/Kconfig
patching file drivers/pci/controller/Makefile
patching file drivers/staging/Kconfig
patching file drivers/staging/Makefile
patching file drivers/staging/mt7621-pci/Kconfig
patching file drivers/staging/mt7621-pci/Makefile
patching file drivers/staging/mt7621-pci/TODO
patching file drivers/staging/mt7621-pci/mediatek,mt7621-pci.txt
patching file drivers/staging/mt7621-pci/pci-mt7621.c
Hunk #1 FAILED at 1.
Not deleting file drivers/staging/mt7621-pci/pci-mt7621.c as content differs from patch
1 out of 1 hunk FAILED -- saving rejects to file drivers/staging/mt7621-pci/pci-mt7621.c.rej
patching file drivers/pci/controller/pcie-mt7621.c
Applied patch platform/100-PCI-mt7621-Add-MediaTek-MT7621-PCIe-host-controller-.patch (forced; needs refresh)
Upon inspecting drivers/staging/mt7621-pci/pci-mt7621.c.rej, it seems that
the original patch wants to delete drivers/staging/mt7621-pci/pci-mt7621.c
but upstream's version was not an exact match. I opted to delete that
file.
5. Suggestion by hauke: 19098934f9
"This patch is in upstream kernel, but it was backported to the old
staging driver in kernel 5.15."
Build system: x86_64
Build-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Run-tested: bcm2711/RPi4B, filogic/xiaomi_redmi-router-ax6000-ubootmod
Signed-off-by: John Audia <therealgraysky@proton.me>
179 lines
4.9 KiB
Diff
179 lines
4.9 KiB
Diff
From ffe387740bbe88dd88bbe04d6375902708003d6e Mon Sep 17 00:00:00 2001
|
|
From: Felix Fietkau <nbd@nbd.name>
|
|
Date: Fri, 7 Jul 2017 17:25:00 +0200
|
|
Subject: net: add packet mangeling
|
|
|
|
ar8216 switches have a hardware bug, which renders normal 802.1q support
|
|
unusable. Packet mangling is required to fix up the vlan for incoming
|
|
packets.
|
|
|
|
Signed-off-by: Felix Fietkau <nbd@nbd.name>
|
|
---
|
|
include/linux/netdevice.h | 11 +++++++++++
|
|
include/linux/skbuff.h | 14 ++++----------
|
|
net/Kconfig | 6 ++++++
|
|
net/core/dev.c | 20 +++++++++++++++-----
|
|
net/core/skbuff.c | 17 +++++++++++++++++
|
|
net/ethernet/eth.c | 6 ++++++
|
|
6 files changed, 59 insertions(+), 15 deletions(-)
|
|
|
|
--- a/include/linux/netdevice.h
|
|
+++ b/include/linux/netdevice.h
|
|
@@ -1676,6 +1676,10 @@ enum netdev_priv_flags {
|
|
IFF_TX_SKB_NO_LINEAR = BIT_ULL(31),
|
|
};
|
|
|
|
+enum netdev_extra_priv_flags {
|
|
+ IFF_NO_IP_ALIGN = 1<<0,
|
|
+};
|
|
+
|
|
#define IFF_802_1Q_VLAN IFF_802_1Q_VLAN
|
|
#define IFF_EBRIDGE IFF_EBRIDGE
|
|
#define IFF_BONDING IFF_BONDING
|
|
@@ -1708,6 +1712,7 @@ enum netdev_priv_flags {
|
|
#define IFF_L3MDEV_RX_HANDLER IFF_L3MDEV_RX_HANDLER
|
|
#define IFF_LIVE_RENAME_OK IFF_LIVE_RENAME_OK
|
|
#define IFF_TX_SKB_NO_LINEAR IFF_TX_SKB_NO_LINEAR
|
|
+#define IFF_NO_IP_ALIGN IFF_NO_IP_ALIGN
|
|
|
|
/* Specifies the type of the struct net_device::ml_priv pointer */
|
|
enum netdev_ml_priv_type {
|
|
@@ -2009,6 +2014,7 @@ struct net_device {
|
|
/* Read-mostly cache-line for fast-path access */
|
|
unsigned int flags;
|
|
unsigned int priv_flags;
|
|
+ unsigned int extra_priv_flags;
|
|
const struct net_device_ops *netdev_ops;
|
|
int ifindex;
|
|
unsigned short gflags;
|
|
@@ -2069,6 +2075,11 @@ struct net_device {
|
|
const struct tlsdev_ops *tlsdev_ops;
|
|
#endif
|
|
|
|
+#ifdef CONFIG_ETHERNET_PACKET_MANGLE
|
|
+ void (*eth_mangle_rx)(struct net_device *dev, struct sk_buff *skb);
|
|
+ struct sk_buff *(*eth_mangle_tx)(struct net_device *dev, struct sk_buff *skb);
|
|
+#endif
|
|
+
|
|
const struct header_ops *header_ops;
|
|
|
|
unsigned char operstate;
|
|
@@ -2143,6 +2154,10 @@ struct net_device {
|
|
struct mctp_dev __rcu *mctp_ptr;
|
|
#endif
|
|
|
|
+#ifdef CONFIG_ETHERNET_PACKET_MANGLE
|
|
+ void *phy_ptr; /* PHY device specific data */
|
|
+#endif
|
|
+
|
|
/*
|
|
* Cache lines mostly used on receive path (including eth_type_trans())
|
|
*/
|
|
--- a/include/linux/skbuff.h
|
|
+++ b/include/linux/skbuff.h
|
|
@@ -2854,6 +2854,10 @@ static inline int pskb_trim(struct sk_bu
|
|
return (len < skb->len) ? __pskb_trim(skb, len) : 0;
|
|
}
|
|
|
|
+extern struct sk_buff *__netdev_alloc_skb_ip_align(struct net_device *dev,
|
|
+ unsigned int length, gfp_t gfp);
|
|
+
|
|
+
|
|
/**
|
|
* pskb_trim_unique - remove end from a paged unique (not cloned) buffer
|
|
* @skb: buffer to alter
|
|
@@ -3004,16 +3008,6 @@ static inline struct sk_buff *dev_alloc_
|
|
}
|
|
|
|
|
|
-static inline struct sk_buff *__netdev_alloc_skb_ip_align(struct net_device *dev,
|
|
- unsigned int length, gfp_t gfp)
|
|
-{
|
|
- struct sk_buff *skb = __netdev_alloc_skb(dev, length + NET_IP_ALIGN, gfp);
|
|
-
|
|
- if (NET_IP_ALIGN && skb)
|
|
- skb_reserve(skb, NET_IP_ALIGN);
|
|
- return skb;
|
|
-}
|
|
-
|
|
static inline struct sk_buff *netdev_alloc_skb_ip_align(struct net_device *dev,
|
|
unsigned int length)
|
|
{
|
|
--- a/net/Kconfig
|
|
+++ b/net/Kconfig
|
|
@@ -26,6 +26,12 @@ menuconfig NET
|
|
|
|
if NET
|
|
|
|
+config ETHERNET_PACKET_MANGLE
|
|
+ bool
|
|
+ help
|
|
+ This option can be selected by phy drivers that need to mangle
|
|
+ packets going in or out of an ethernet device.
|
|
+
|
|
config WANT_COMPAT_NETLINK_MESSAGES
|
|
bool
|
|
help
|
|
--- a/net/core/dev.c
|
|
+++ b/net/core/dev.c
|
|
@@ -3588,6 +3588,11 @@ static int xmit_one(struct sk_buff *skb,
|
|
if (dev_nit_active(dev))
|
|
dev_queue_xmit_nit(skb, dev);
|
|
|
|
+#ifdef CONFIG_ETHERNET_PACKET_MANGLE
|
|
+ if (dev->eth_mangle_tx && !(skb = dev->eth_mangle_tx(dev, skb)))
|
|
+ return NETDEV_TX_OK;
|
|
+#endif
|
|
+
|
|
len = skb->len;
|
|
PRANDOM_ADD_NOISE(skb, dev, txq, len + jiffies);
|
|
trace_net_dev_start_xmit(skb, dev);
|
|
--- a/net/core/skbuff.c
|
|
+++ b/net/core/skbuff.c
|
|
@@ -61,6 +61,7 @@
|
|
#include <linux/if_vlan.h>
|
|
#include <linux/mpls.h>
|
|
#include <linux/kcov.h>
|
|
+#include <linux/if.h>
|
|
|
|
#include <net/protocol.h>
|
|
#include <net/dst.h>
|
|
@@ -602,6 +603,22 @@ skb_fail:
|
|
}
|
|
EXPORT_SYMBOL(__napi_alloc_skb);
|
|
|
|
+struct sk_buff *__netdev_alloc_skb_ip_align(struct net_device *dev,
|
|
+ unsigned int length, gfp_t gfp)
|
|
+{
|
|
+ struct sk_buff *skb = __netdev_alloc_skb(dev, length + NET_IP_ALIGN, gfp);
|
|
+
|
|
+#ifdef CONFIG_ETHERNET_PACKET_MANGLE
|
|
+ if (dev && (dev->extra_priv_flags & IFF_NO_IP_ALIGN))
|
|
+ return skb;
|
|
+#endif
|
|
+
|
|
+ if (NET_IP_ALIGN && skb)
|
|
+ skb_reserve(skb, NET_IP_ALIGN);
|
|
+ return skb;
|
|
+}
|
|
+EXPORT_SYMBOL(__netdev_alloc_skb_ip_align);
|
|
+
|
|
void skb_add_rx_frag(struct sk_buff *skb, int i, struct page *page, int off,
|
|
int size, unsigned int truesize)
|
|
{
|
|
--- a/net/ethernet/eth.c
|
|
+++ b/net/ethernet/eth.c
|
|
@@ -170,6 +170,12 @@ __be16 eth_type_trans(struct sk_buff *sk
|
|
const struct ethhdr *eth;
|
|
|
|
skb->dev = dev;
|
|
+
|
|
+#ifdef CONFIG_ETHERNET_PACKET_MANGLE
|
|
+ if (dev->eth_mangle_rx)
|
|
+ dev->eth_mangle_rx(dev, skb);
|
|
+#endif
|
|
+
|
|
skb_reset_mac_header(skb);
|
|
|
|
eth = (struct ethhdr *)skb->data;
|