mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
20ea6adbf1
Build system: x86_64 Build-tested: bcm2708, bcm2709, bcm2710, bcm2711 Run-tested: bcm2708/RPiB+, bcm2709/RPi3B, bcm2710/RPi3B, bcm2711/RPi4B Signed-off-by: Marty Jones <mj8263788@gmail.com> Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
From a940e0dff79259844e576ad6604ce00dee976c6c Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.com>
|
|
Date: Fri, 29 Jan 2021 10:34:11 +0000
|
|
Subject: [PATCH] kbuild: Silence unavoidable dtc overlay warnings
|
|
|
|
Much effort has been put into finding ways to avoid warnings from dtc
|
|
about overlays, usually to do with the presence of #address-cells and
|
|
size-cells, but not exclusively so. Since the issues being warned about
|
|
are harmless, suppress the warnings to declutter the build output and
|
|
to avoid alarming users.
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.com>
|
|
---
|
|
scripts/Makefile.lib | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
--- a/scripts/Makefile.lib
|
|
+++ b/scripts/Makefile.lib
|
|
@@ -380,6 +380,12 @@ cmd_dtco = mkdir -p $(dir ${dtc-tmp}) ;
|
|
$(DTC) -@ -H epapr -O dtb -o $@ -b 0 \
|
|
-i $(dir $<) $(DTC_FLAGS) \
|
|
-Wno-interrupts_property \
|
|
+ -Wno-label_is_string \
|
|
+ -Wno-reg_format \
|
|
+ -Wno-pci_device_bus_num \
|
|
+ -Wno-i2c_bus_reg \
|
|
+ -Wno-spi_bus_reg \
|
|
+ -Wno-avoid_default_addr_size \
|
|
-d $(depfile).dtc.tmp $(dtc-tmp) ; \
|
|
cat $(depfile).pre.tmp $(depfile).dtc.tmp > $(depfile)
|
|
|