mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
0989b7ad3a
Removed upstreamed: bcm4908/patches-5.10/180-i2c-brcmstb-fix-support-for-DSL-and-CM-variants.patch[1] All other patches automatically rebased. 1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.102&id=f333c1916fd6b55900029bf8f918cc00009e2111 Build system: x86_64 Build-tested: bcm2711/RPi4B, mt7622/RT3200 Run-tested: bcm2711/RPi4B, mt7622/RT3200 Signed-off-by: John Audia <graysky@archlinux.us>
69 lines
2.4 KiB
Diff
69 lines
2.4 KiB
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -341,6 +341,13 @@ config GPIO_IXP4XX
|
|
IXP4xx series of chips.
|
|
|
|
If unsure, say N.
|
|
+
|
|
+config GPIO_LATCH
|
|
+ tristate "MikroTik RouterBOARD GPIO latch support"
|
|
+ depends on ATH79
|
|
+ help
|
|
+ GPIO driver for latch on some MikroTik RouterBOARDs.
|
|
+
|
|
config GPIO_LOGICVC
|
|
tristate "Xylon LogiCVC GPIO support"
|
|
depends on MFD_SYSCON && OF
|
|
@@ -495,6 +502,10 @@ config GPIO_REG
|
|
A 32-bit single register GPIO fixed in/out implementation. This
|
|
can be used to represent any register as a set of GPIO signals.
|
|
|
|
+config GPIO_RB91X_KEY
|
|
+ tristate "MikroTik RB91x board series reset key support"
|
|
+ depends on ATH79
|
|
+
|
|
config GPIO_SAMA5D2_PIOBU
|
|
tristate "SAMA5D2 PIOBU GPIO support"
|
|
depends on MFD_SYSCON
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -73,6 +73,7 @@ obj-$(CONFIG_GPIO_IT87) += gpio-it87.o
|
|
obj-$(CONFIG_GPIO_IXP4XX) += gpio-ixp4xx.o
|
|
obj-$(CONFIG_GPIO_JANZ_TTL) += gpio-janz-ttl.o
|
|
obj-$(CONFIG_GPIO_KEMPLD) += gpio-kempld.o
|
|
+obj-$(CONFIG_GPIO_LATCH) += gpio-latch.o
|
|
obj-$(CONFIG_GPIO_LOGICVC) += gpio-logicvc.o
|
|
obj-$(CONFIG_GPIO_LOONGSON1) += gpio-loongson1.o
|
|
obj-$(CONFIG_GPIO_LOONGSON) += gpio-loongson.o
|
|
@@ -122,6 +123,7 @@ obj-$(CONFIG_GPIO_PMIC_EIC_SPRD) += gpio
|
|
obj-$(CONFIG_GPIO_PXA) += gpio-pxa.o
|
|
obj-$(CONFIG_GPIO_RASPBERRYPI_EXP) += gpio-raspberrypi-exp.o
|
|
obj-$(CONFIG_GPIO_RB4XX) += gpio-rb4xx.o
|
|
+obj-$(CONFIG_GPIO_RB91X_KEY) += gpio-rb91x-key.o
|
|
obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t583.o
|
|
obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
|
|
obj-$(CONFIG_GPIO_RDA) += gpio-rda.o
|
|
--- a/drivers/mtd/nand/raw/Kconfig
|
|
+++ b/drivers/mtd/nand/raw/Kconfig
|
|
@@ -571,4 +571,10 @@ config MTD_NAND_RB4XX
|
|
Enables support for the NAND flash chip on Mikrotik Routerboard
|
|
RB4xx series.
|
|
|
|
+config MTD_NAND_RB91X
|
|
+ tristate "MikroTik RB91x NAND driver support"
|
|
+ depends on ATH79 && MTD_RAW_NAND
|
|
+ help
|
|
+ Enables support for the NAND flash chip on MikroTik RB91x series.
|
|
+
|
|
endif # MTD_RAW_NAND
|
|
--- a/drivers/mtd/nand/raw/Makefile
|
|
+++ b/drivers/mtd/nand/raw/Makefile
|
|
@@ -60,6 +60,7 @@ obj-$(CONFIG_MTD_NAND_CADENCE) += caden
|
|
obj-$(CONFIG_MTD_NAND_ARASAN) += arasan-nand-controller.o
|
|
obj-$(CONFIG_MTD_NAND_AR934X) += ar934x_nand.o
|
|
obj-$(CONFIG_MTD_NAND_RB4XX) += nand_rb4xx.o
|
|
+obj-$(CONFIG_MTD_NAND_RB91X) += rb91x_nand.o
|
|
|
|
nand-objs := nand_base.o nand_legacy.o nand_bbt.o nand_timings.o nand_ids.o
|
|
nand-objs += nand_onfi.o
|