mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-22 15:02:32 +00:00
ee6349fbe5
Add a driver for controlling the RGB LED via Ubiquitis own "LEDBAR" LED
controller based on the Holtek HT32F52241 MCU.
This driver is initially used by the Ubiquiti UniFi 6 LR, however
judging from FCC pictures the MCU is also found on the U6-Mesh as well
as the U6-Extender.
Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit c9137e2ddf
)
30 lines
955 B
Diff
30 lines
955 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -823,6 +823,16 @@ config LEDS_LM36274
|
|
Say Y to enable the LM36274 LED driver for TI LMU devices.
|
|
This supports the LED device LM36274.
|
|
|
|
+config LEDS_UBNT_LEDBAR
|
|
+ tristate "LED support for Ubiquiti UniFi 6 LR"
|
|
+ depends on LEDS_CLASS && I2C && OF
|
|
+ help
|
|
+ This option enables support for the Ubiquiti LEDBAR
|
|
+ LED driver.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module
|
|
+ will be called leds-ubnt-ledbar.
|
|
+
|
|
comment "LED Triggers"
|
|
source "drivers/leds/trigger/Kconfig"
|
|
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -85,6 +85,7 @@ obj-$(CONFIG_LEDS_LM3601X) += leds-lm36
|
|
obj-$(CONFIG_LEDS_TI_LMU_COMMON) += leds-ti-lmu-common.o
|
|
obj-$(CONFIG_LEDS_LM3697) += leds-lm3697.o
|
|
obj-$(CONFIG_LEDS_LM36274) += leds-lm36274.o
|
|
+obj-$(CONFIG_LEDS_UBNT_LEDBAR) += leds-ubnt-ledbar.o
|
|
|
|
# LED SPI Drivers
|
|
obj-$(CONFIG_LEDS_CR0014114) += leds-cr0014114.o
|