mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 14:13:16 +00:00
765f66810a
Hardware -------- SoC: NXP P1010 (1x e500 @ 800MHz) RAM: 256M DDR3 (2x Samsung K4B1G1646G-BCH9) FLASH: 32M NOR (Spansion S25FL256S) BTN: 1x Reset WiFi: 1x Atheros AR9590 2.4 bgn 3x3 2x Atheros AR9590 5.0 an 3x3 ETH: 2x Gigabit Ethernet (Atheros AR8033 / AR8035) UART: 115200 8N1 (RJ-45 Cisco) Installation ------------ 1. Grab the OpenWrt initramfs, rename it to ap3715.bin. Place it in the root directory of a TFTP server and serve it at 192.168.1.66/24. 2. Connect to the serial port and boot the AP. Stop autoboot in U-Boot by pressing Enter when prompted. Credentials are identical to the one in the APs interface. By default it is admin / new2day. 3. Alter the bootcmd in U-Boot: $ setenv ramboot_openwrt "setenv ipaddr 192.168.1.1; setenv serverip 192.168.1.66; tftpboot 0x2000000 ap3715.bin; bootm" $ setenv boot_openwrt "sf probe 0; sf read 0x2000000 0x140000 0x1000000; bootm 0x2000000" $ setenv bootcmd "run boot_openwrt" $ saveenv 4. Boot the initramfs image $ run ramboot_openwrt 5. Transfer the OpenWrt sysupgrade image to the AP using SCP. Install using sysupgrade. $ sysupgrade -n <path-to-sysupgrade.bin> Signed-off-by: David Bauer <mail@david-bauer.net>
51 lines
1.8 KiB
Diff
51 lines
1.8 KiB
Diff
--- a/arch/powerpc/platforms/85xx/Kconfig
|
|
+++ b/arch/powerpc/platforms/85xx/Kconfig
|
|
@@ -82,6 +82,17 @@ config WS_AP3710I
|
|
This board is a Concurrent Dual-Band wireless access point with a
|
|
Freescale P1020 SoC.
|
|
|
|
+config WS_AP3715I
|
|
+ bool "Enterasys WS-AP3715i"
|
|
+ select DEFAULT_UIMAGE
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select GPIO_MPC8XXX
|
|
+ help
|
|
+ This option enables support for the Enterasys WS-AP3715i board.
|
|
+
|
|
+ This board is a Concurrent Dual-Band wireless access point with a
|
|
+ Freescale P1010 SoC.
|
|
+
|
|
config WS_AP3825I
|
|
bool "Extreme Networks WS-AP3825i"
|
|
select DEFAULT_UIMAGE
|
|
--- a/arch/powerpc/platforms/85xx/Makefile
|
|
+++ b/arch/powerpc/platforms/85xx/Makefile
|
|
@@ -27,6 +27,7 @@ obj-$(CONFIG_P1023_RDB) += p1023_rdb.o
|
|
obj-$(CONFIG_PANDA) += panda.o
|
|
obj-$(CONFIG_TWR_P102x) += twr_p102x.o
|
|
obj-$(CONFIG_WS_AP3710I) += ws-ap3710i.o
|
|
+obj-$(CONFIG_WS_AP3715I) += ws-ap3715i.o
|
|
obj-$(CONFIG_WS_AP3825I) += ws-ap3825i.o
|
|
obj-$(CONFIG_FIREBOX_T10) += firebox_t10.o
|
|
obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o
|
|
--- a/arch/powerpc/boot/Makefile
|
|
+++ b/arch/powerpc/boot/Makefile
|
|
@@ -346,6 +346,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm
|
|
image-$(CONFIG_TQM8560) += cuImage.tqm8560
|
|
image-$(CONFIG_KSI8560) += cuImage.ksi8560
|
|
image-$(CONFIG_TL_WDR4900_V1) += simpleImage.tl-wdr4900-v1
|
|
+image-$(CONFIG_WS_AP3715I) += simpleImage.ws-ap3715i
|
|
image-$(CONFIG_WS_AP3825I) += simpleImage.ws-ap3825i
|
|
# Board ports in arch/powerpc/platform/86xx/Kconfig
|
|
image-$(CONFIG_MVME7100) += dtbImage.mvme7100
|
|
--- a/arch/powerpc/boot/wrapper
|
|
+++ b/arch/powerpc/boot/wrapper
|
|
@@ -326,6 +326,7 @@ adder875-redboot)
|
|
platformo="$object/fixed-head.o $object/redboot-8xx.o"
|
|
binary=y
|
|
;;
|
|
+simpleboot-ws-ap3715i|\
|
|
simpleboot-ws-ap3825i|\
|
|
simpleboot-tl-wdr4900-v1)
|
|
platformo="$object/fixed-head.o $object/simpleboot.o"
|