mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-20 22:23:27 +00:00
9261e7447e
This makes the patches which were just copied in the previous commit apply on top of kernel 4.19. The patches in the backports-4.19 folder were checked if they are really in kernel 4.19 based on the title and only removed if they were found in the upstream kernel. The following additional patches form the pending folder went into upstream Linux 4.19: pending-4.19/171-usb-dwc2-Fix-inefficient-copy-of-unaligned-buffers.patch pending-4.19/190-2-5-e1000e-Fix-wrong-comment-related-to-link-detection.patch pending-4.19/478-mtd-spi-nor-Add-support-for-XM25QH64A-and-XM25QH128A.patch pending-4.19/479-mtd-spi-nor-add-eon-en25qh32.patch pending-4.19/950-tty-serial-exar-generalize-rs485-setup.patch pending-4.19/340-MIPS-mm-remove-mips_dma_mapping_error.patch Bigger changes were introduced to the m25p80 spi nor driver, as far as I saw it in the new code, it now has the functionality provided in this patch: pending-4.19/450-mtd-m25p80-allow-fallback-from-spi_flash_read-to-reg.patch Part of this patch went upstream independent of OpenWrt: hack-4.19/220-gc_sections.patch This patch was reworked to match the changes done upstream. The MIPS DMA API changed a lot, this patch was rewritten to match the new DMA handling: pending-4.19/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch I did bigger manual changes to the following patches and I am not 100% sure if they are all correct: pending-4.19/0931-w1-gpio-fix-problem-with-platfom-data-in-w1-gpio.patch pending-4.19/411-mtd-partial_eraseblock_write.patch pending-4.19/600-netfilter_conntrack_flush.patch pending-4.19/611-netfilter_match_bypass_default_table.patch pending-4.19/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch hack-4.19/211-host_tools_portability.patch hack-4.19/221-module_exports.patch hack-4.19/321-powerpc_crtsavres_prereq.patch hack-4.19/902-debloat_proc.patch This is based on patchset from Marko Ratkaj <marko.ratkaj@sartura.hr> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
85 lines
2.3 KiB
Diff
85 lines
2.3 KiB
Diff
From 236c1acdfef5958010ac9814a9872e0a46fd78ee Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <john@phrozen.org>
|
|
Date: Fri, 7 Jul 2017 17:13:44 +0200
|
|
Subject: rfkill: add fake rfkill support
|
|
|
|
allow building of modules depending on RFKILL even if RFKILL is not enabled.
|
|
|
|
Signed-off-by: John Crispin <john@phrozen.org>
|
|
---
|
|
include/linux/rfkill.h | 2 +-
|
|
net/Makefile | 2 +-
|
|
net/rfkill/Kconfig | 14 +++++++++-----
|
|
net/rfkill/Makefile | 2 +-
|
|
4 files changed, 12 insertions(+), 8 deletions(-)
|
|
|
|
--- a/include/linux/rfkill.h
|
|
+++ b/include/linux/rfkill.h
|
|
@@ -64,7 +64,7 @@ struct rfkill_ops {
|
|
int (*set_block)(void *data, bool blocked);
|
|
};
|
|
|
|
-#if defined(CONFIG_RFKILL) || defined(CONFIG_RFKILL_MODULE)
|
|
+#if defined(CONFIG_RFKILL_FULL) || defined(CONFIG_RFKILL_FULL_MODULE)
|
|
/**
|
|
* rfkill_alloc - Allocate rfkill structure
|
|
* @name: name of the struct -- the string is not copied internally
|
|
--- a/net/Makefile
|
|
+++ b/net/Makefile
|
|
@@ -53,7 +53,7 @@ obj-$(CONFIG_TIPC) += tipc/
|
|
obj-$(CONFIG_NETLABEL) += netlabel/
|
|
obj-$(CONFIG_IUCV) += iucv/
|
|
obj-$(CONFIG_SMC) += smc/
|
|
-obj-$(CONFIG_RFKILL) += rfkill/
|
|
+obj-$(CONFIG_RFKILL_FULL) += rfkill/
|
|
obj-$(CONFIG_NET_9P) += 9p/
|
|
obj-$(CONFIG_CAIF) += caif/
|
|
ifneq ($(CONFIG_DCB),)
|
|
--- a/net/rfkill/Kconfig
|
|
+++ b/net/rfkill/Kconfig
|
|
@@ -1,7 +1,11 @@
|
|
#
|
|
# RF switch subsystem configuration
|
|
#
|
|
-menuconfig RFKILL
|
|
+config RFKILL
|
|
+ bool
|
|
+ default y
|
|
+
|
|
+menuconfig RFKILL_FULL
|
|
tristate "RF switch subsystem support"
|
|
help
|
|
Say Y here if you want to have control over RF switches
|
|
@@ -13,19 +17,19 @@ menuconfig RFKILL
|
|
# LED trigger support
|
|
config RFKILL_LEDS
|
|
bool
|
|
- depends on RFKILL
|
|
+ depends on RFKILL_FULL
|
|
depends on LEDS_TRIGGERS = y || RFKILL = LEDS_TRIGGERS
|
|
default y
|
|
|
|
config RFKILL_INPUT
|
|
bool "RF switch input support" if EXPERT
|
|
- depends on RFKILL
|
|
+ depends on RFKILL_FULL
|
|
depends on INPUT = y || RFKILL = INPUT
|
|
default y if !EXPERT
|
|
|
|
config RFKILL_GPIO
|
|
tristate "GPIO RFKILL driver"
|
|
- depends on RFKILL
|
|
+ depends on RFKILL_FULL
|
|
depends on GPIOLIB || COMPILE_TEST
|
|
default n
|
|
help
|
|
--- a/net/rfkill/Makefile
|
|
+++ b/net/rfkill/Makefile
|
|
@@ -4,5 +4,5 @@
|
|
|
|
rfkill-y += core.o
|
|
rfkill-$(CONFIG_RFKILL_INPUT) += input.o
|
|
-obj-$(CONFIG_RFKILL) += rfkill.o
|
|
+obj-$(CONFIG_RFKILL_FULL) += rfkill.o
|
|
obj-$(CONFIG_RFKILL_GPIO) += rfkill-gpio.o
|