mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-26 00:41:17 +00:00
f1f97db627
OpenWRT's developer guide prefers having actual patches so they an be sent upstream more easily. However, in this case, Adding proper fields also allows for `git am` to properly function. Some of these patches are quite old, and lack much traceable history. This commit tries to rectify that, by digging in the history to find where and how it was first added. It is by no means perfect and also shows some patches that should have been long gone. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
47 lines
1.7 KiB
Diff
47 lines
1.7 KiB
Diff
From 63a0a4d85bc900464c5b046b13808a582345f8c8 Mon Sep 17 00:00:00 2001
|
|
From: Birger Koblitz <git@birger-koblitz.de>
|
|
Date: Sat, 11 Dec 2021 20:14:47 +0100
|
|
Subject: [PATCH] realtek: Add support for RTL9300/RTL9310 I2C controller
|
|
|
|
This adds support for the RTL9300 and RTL9310 I2C controller.
|
|
The controller implements the SMBus protocol for SMBus transfers
|
|
over an I2C bus. The driver supports selecting one of the 2 possible
|
|
SCL pins and any of the 8 possible SDA pins. Bus speeds of
|
|
100kHz (standard speed) and 400kHz (high speed I2C) are supported.
|
|
|
|
Submitted-by: Birger Koblitz <git@birger-koblitz.de>
|
|
---
|
|
drivers/i2c/busses/Kconfig | 10 +++++++++
|
|
drivers/i2c/busses/Makefile | 1 +
|
|
2 files changed, 11 insertions(+)
|
|
|
|
--- a/drivers/i2c/busses/Kconfig
|
|
+++ b/drivers/i2c/busses/Kconfig
|
|
@@ -954,6 +954,16 @@ config I2C_RK3X
|
|
This driver can also be built as a module. If so, the module will
|
|
be called i2c-rk3x.
|
|
|
|
+config I2C_RTL9300
|
|
+ tristate "Realtek RTL9300 I2C adapter"
|
|
+ depends on OF
|
|
+ help
|
|
+ Say Y here to include support for the I2C adapter in Realtek RTL9300
|
|
+ and RTL9310 SoCs.
|
|
+
|
|
+ This driver can also be built as a module. If so, the module will
|
|
+ be called i2c-rtl9300.
|
|
+
|
|
config HAVE_S3C2410_I2C
|
|
bool
|
|
help
|
|
--- a/drivers/i2c/busses/Makefile
|
|
+++ b/drivers/i2c/busses/Makefile
|
|
@@ -95,6 +95,7 @@ obj-$(CONFIG_I2C_QCOM_GENI) += i2c-qcom-
|
|
obj-$(CONFIG_I2C_QUP) += i2c-qup.o
|
|
obj-$(CONFIG_I2C_RIIC) += i2c-riic.o
|
|
obj-$(CONFIG_I2C_RK3X) += i2c-rk3x.o
|
|
+obj-$(CONFIG_I2C_RTL9300) += i2c-rtl9300.o
|
|
obj-$(CONFIG_I2C_S3C2410) += i2c-s3c2410.o
|
|
obj-$(CONFIG_I2C_SH7760) += i2c-sh7760.o
|
|
obj-$(CONFIG_I2C_SH_MOBILE) += i2c-sh_mobile.o
|