mirror of
https://github.com/openwrt/openwrt.git
synced 2024-12-28 09:39:00 +00:00
2c2fcbd2e0
Manually merged: hack-5.4 230-openwrt_lzma_options.patch bcm27xx 950-0283-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch x86 011-tune_lzma_options.patch Remove upstreamed patches in collaboration with Ansuel Smith: ipq806x 093-1-v5.8-ipq806x-PCI-qcom-Add-missing-ipq806x-clocks-in-PCIe-driver.patch 093-2-v5.8-ipq806x-PCI-qcom-Change-duplicate-PCI-reset-to-phy-reset.patch 093-3-v5.8-ipq806x-PCI-qcom-Add-missing-reset-for-ipq806x.patch All other modifications made by update_kernel.sh Build-tested: bcm27xx/bcm2708, ipq806x, x86/64 Run-tested: ipq806x (R7800), x86/64 No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us> [update commit message/tested] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
37 lines
1.2 KiB
Diff
37 lines
1.2 KiB
Diff
From 7542fb08d2726606057c4283b3a454abb195a0f5 Mon Sep 17 00:00:00 2001
|
|
From: Phil Elwell <phil@raspberrypi.org>
|
|
Date: Mon, 23 Sep 2019 09:26:41 +0100
|
|
Subject: [PATCH] kbuild: Allow .dtbo overlays to be built piecemeal
|
|
|
|
Before 4.20, it was possible to build an arbitrary overlay by copying
|
|
it to arm/boot/dts/overlays/mytest-overlay.dts and running:
|
|
|
|
make ARCH=arm overlays/mytest.dtbo
|
|
|
|
In 4.20 the .dtb build rules were centralised, requiring the dowstream
|
|
.dtbo build rules to be changed. They were, enough to support "make ...
|
|
dtbs", but not sufficiently to allow this ad-hoc, one-off building of
|
|
individual files.
|
|
|
|
Add the missing makefile rule to support this way of building.
|
|
|
|
See: https://github.com/raspberrypi/linux/issues/3250
|
|
|
|
Signed-off-by: Phil Elwell <phil@raspberrypi.org>
|
|
---
|
|
Makefile | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1264,6 +1264,9 @@ ifneq ($(dtstree),)
|
|
%.dtb: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
|
|
+%.dtbo: prepare3 scripts_dtc
|
|
+ $(Q)$(MAKE) $(build)=$(dtstree) $(dtstree)/$@
|
|
+
|
|
PHONY += dtbs dtbs_install dtbs_check
|
|
dtbs: include/config/kernel.release scripts_dtc
|
|
$(Q)$(MAKE) $(build)=$(dtstree)
|